CVE-2021-43561 Cross-site Scripting in pegasus/google-for-jobs
Cross-site scripting in Google for Jobs extension allows backend users to inject scripts, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-43561?
CVE-2021-43561 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
An XSS issue was discovered in the google_for_jobs (aka Google for Jobs) extension before 1.5.1 and 2.x before 2.1.1 for TYPO3. The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.
Weakness: CWE-79
Which versions are affected by CVE-2021-43561?
4 open source packages ship an affected version, including pegasus/google-for-jobs. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
pegasus/google-for-jobs Packagist | All versions | 1.5.1 |
pegasus/google-for-jobs Packagist | All versions | 1.5.1 |
pegasus/google-for-jobs Packagist | From 2.0.0 | 2.1.1 |
pegasus/google-for-jobs Packagist | From 2.0.0 | 2.1.1 |
Products include Pega-Sus Google for Jobs.
How do I fix CVE-2021-43561?
Upgrade pegasus/google-for-jobs to a fixed version for your release line: 1.5.1 or 2.1.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-43561 being exploited?
There is no known exploitation of CVE-2021-43561 in the wild and no public exploit code.
Sources
Also known as GHSA-hfm8-2q22-h7hv.