{"answers":{"affected":"4 open source packages ship an affected version, including pegasus/google-for-jobs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-43561 in the wild and no public exploit code.","fix":"Upgrade pegasus/google-for-jobs to a fixed version for your release line: 1.5.1 or 2.1.1.","what":"CVE-2021-43561 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-43561 and fix it if it is affected.\n\nWhat it is: CVE-2021-43561 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-43561 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pegasus/google-for-jobs (Packagist): affected all versions; fixed in 1.5.1\n- pegasus/google-for-jobs (Packagist): affected all versions; fixed in 1.5.1\n- pegasus/google-for-jobs (Packagist): affected from 2.0.0; fixed in 2.1.1\n- pegasus/google-for-jobs (Packagist): affected from 2.0.0; fixed in 2.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43561/ (Markdown: https://insights.sbomify.com/CVE-2021-43561/index.md)","id":"CVE-2021-43561","markdown":"https://insights.sbomify.com/CVE-2021-43561/index.md","name":"CVE-2021-43561","record":{"aliases":["GHSA-hfm8-2q22-h7hv"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"TYPO3 extension","requires_auth":"low_privilege","summary":"Cross-site scripting in Google for Jobs extension allows backend users to inject scripts, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"google_for_jobs","vendor":"pega-sus"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An XSS issue was discovered in the google_for_jobs (aka Google for Jobs) extension before 1.5.1 and 2.x before 2.1.1 for TYPO3. The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in pegasus/google-for-jobs","id":"CVE-2021-43561","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":4,"n_references":1,"next":{"headline":"Server-side request forgery in n/a","id":"CVE-2021-43562"},"packages":[{"ecosystem":"Packagist","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"pegasus/google-for-jobs","purl":null,"source":"GHSA-hfm8-2q22-h7hv"},{"ecosystem":"Packagist","fixed":["1.5.1"],"introduced":["0"],"last_affected":[],"package":"pegasus/google-for-jobs","purl":"pkg:composer/pegasus/google-for-jobs","source":"GHSA-hfm8-2q22-h7hv"},{"ecosystem":"Packagist","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"pegasus/google-for-jobs","purl":null,"source":"GHSA-hfm8-2q22-h7hv"},{"ecosystem":"Packagist","fixed":["2.1.1"],"introduced":["2.0.0"],"last_affected":[],"package":"pegasus/google-for-jobs","purl":"pkg:composer/pegasus/google-for-jobs","source":"GHSA-hfm8-2q22-h7hv"}],"prev":{"headline":"Moodle Insecure direct object reference (IDOR) in a calendar web service","id":"CVE-2021-43560"},"products":["n/a"],"published":"2021-11-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Cross-site scripting in Google for Jobs extension allows backend users to inject scripts, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2021-43561/"}