# CVE-2021-43561: Cross-site Scripting in pegasus/google-for-jobs

> Cross-site scripting in Google for Jobs extension allows backend users to inject scripts, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hfm8-2q22-h7hv

## What is CVE-2021-43561?

CVE-2021-43561 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An XSS issue was discovered in the google_for_jobs (aka Google for Jobs) extension before 1.5.1 and 2.x before 2.1.1 for TYPO3. The extension fails to properly encode user input for output in HTML context. A TYPO3 backend user account is required to exploit the vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-43561?

4 open source packages ship an affected version, including pegasus/google-for-jobs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pegasus/google-for-jobs` | Packagist | All versions | 1.5.1 |
| `pegasus/google-for-jobs` | Packagist | All versions | 1.5.1 |
| `pegasus/google-for-jobs` | Packagist | From 2.0.0 | 2.1.1 |
| `pegasus/google-for-jobs` | Packagist | From 2.0.0 | 2.1.1 |

Products: Pega-Sus Google for Jobs.

## How do I fix CVE-2021-43561?

Upgrade pegasus/google-for-jobs to a fixed version for your release line: 1.5.1 or 2.1.1.

## Is CVE-2021-43561 being exploited?

There is no known exploitation of CVE-2021-43561 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43561 and fix it if it is affected.

What it is: CVE-2021-43561 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Nov 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-43561 in the wild and no public exploit code.

Affected packages and fixed versions:
- pegasus/google-for-jobs (Packagist): affected all versions; fixed in 1.5.1
- pegasus/google-for-jobs (Packagist): affected all versions; fixed in 1.5.1
- pegasus/google-for-jobs (Packagist): affected from 2.0.0; fixed in 2.1.1
- pegasus/google-for-jobs (Packagist): affected from 2.0.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43561/ (Markdown: https://insights.sbomify.com/CVE-2021-43561/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43561
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43561
- OSV: https://osv.dev/vulnerability/CVE-2021-43561

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43561/
Summaries are generated and may contain mistakes; the official description above is the record.
