CVE-2021-43570 Improper Verification of Cryptographic Signature in starkbank-ecdsa
Critical 9.8
Published
Updated
Check this codebase for CVE-2021-43570 and fix it if it is affected.
What it is: CVE-2021-43570 is a critical vulnerability in n/a, published on 9 Nov 2021.
Exploitation: There is no known exploitation of CVE-2021-43570 in the wild and no public exploit code.
Affected packages and fixed versions:
- com.starkbank.ellipticcurve:starkbank-ecdsa (Maven): affected all versions; fixed in 1.0.1
- com.starkbank.ellipticcurve:starkbank-ecdsa (Maven): affected all versions; fixed in 1.0.1
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2021-43570/ (Markdown: https://insights.sbomify.com/CVE-2021-43570/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2021-43570?
CVE-2021-43570 is a critical vulnerability in n/a, published on 9 Nov 2021.
Official description
The verify function in the Stark Bank Java ECDSA library (ecdsa-java) 1.0.0 fails to check that the signature is non-zero, which allows attackers to forge signatures on arbitrary messages.
Weakness: CWE-347
Which versions are affected by CVE-2021-43570?
2 open source packages ship an affected version, including com.starkbank.ellipticcurve:starkbank-ecdsa. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
com.starkbank.ellipticcurve:starkbank-ecdsa Maven | All versions | 1.0.1 |
com.starkbank.ellipticcurve:starkbank-ecdsa Maven | All versions | 1.0.1 |
Products include Starkbank Ecdsa-Java.
How do I fix CVE-2021-43570?
Upgrade com.starkbank.ellipticcurve:starkbank-ecdsa to 1.0.1 or later.
Is CVE-2021-43570 being exploited?
There is no known exploitation of CVE-2021-43570 in the wild and no public exploit code.
Sources
Also known as GHSA-r28h-x6hv-2fq3.