# CVE-2021-43572: Improper Verification of Cryptographic Signature in starkbank-ecdsa

> Attackers can forge signatures on arbitrary messages due to missing non-zero checks in the Stark Bank Python ECDSA library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-92vm-mxjf-jqf3, PYSEC-2021-426

## What is CVE-2021-43572?

CVE-2021-43572 is a critical vulnerability in n/a, published on 9 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The verify function in the Stark Bank Python ECDSA library (aka starkbank-escada or ecdsa-python) before 2.0.1 fails to check that the signature is non-zero, which allows attackers to forge signatures on arbitrary messages.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2021-43572?

3 open source packages ship an affected version, including starkbank-ecdsa. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `starkbank-ecdsa` | PyPI | All versions | 2.0.1 |
| `starkbank-ecdsa` | PyPI | All versions | 2.0.1 |
| `starkbank-ecdsa` | PyPI | All versions | 2.0.1 |

Products: Starkbank Ecdsa-Python.

## How do I fix CVE-2021-43572?

Upgrade starkbank-ecdsa to 2.0.1 or later.

## Is CVE-2021-43572 being exploited?

There is no known exploitation of CVE-2021-43572 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43572 and fix it if it is affected.

What it is: CVE-2021-43572 is a critical vulnerability in n/a, published on 9 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43572 in the wild and no public exploit code.

Affected packages and fixed versions:
- starkbank-ecdsa (PyPI): affected all versions; fixed in 2.0.1
- starkbank-ecdsa (PyPI): affected all versions; fixed in 2.0.1
- starkbank-ecdsa (PyPI): affected all versions; fixed in 2.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43572/ (Markdown: https://insights.sbomify.com/CVE-2021-43572/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43572
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43572
- OSV: https://osv.dev/vulnerability/CVE-2021-43572

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43572/
Summaries are generated and may contain mistakes; the official description above is the record.
