{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:dependency-check-jenkins-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-43577 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:dependency-check-jenkins-plugin to 5.1.2 or later.","what":"CVE-2021-43577 is a high-severity vulnerability in Jenkins OWASP Dependency-Check Plugin, published on 12 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-43577 and fix it if it is affected.\n\nWhat it is: CVE-2021-43577 is a high-severity vulnerability in Jenkins OWASP Dependency-Check Plugin, published on 12 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-43577 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven): affected all versions; fixed in 5.1.2\n- org.jenkins-ci.plugins:dependency-check-jenkins-plugin (Maven): affected all versions; fixed in 5.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43577/ (Markdown: https://insights.sbomify.com/CVE-2021-43577/index.md)","id":"CVE-2021-43577","markdown":"https://insights.sbomify.com/CVE-2021-43577/index.md","name":"CVE-2021-43577","record":{"aliases":["GHSA-mj5v-ggjc-48p5"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"low_privilege","summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins OWASP Dependency-Check Plugin to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"owasp_dependency-check","vendor":"jenkins"}],"cvss":{"score":7.1,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Jenkins OWASP Dependency-Check Plugin 5.1.1 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability in Jenkins OWASP Dependency-Check Plugin","id":"CVE-2021-43577","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Agent-to-controller security bypass in Jenkins Squash TM Publisher (Squash4Jenkins) Plugin allows writing arbitrary files","id":"CVE-2021-43578"},"packages":[{"ecosystem":"Maven","fixed":["5.1.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:dependency-check-jenkins-plugin","purl":null,"source":"GHSA-mj5v-ggjc-48p5"},{"ecosystem":"Maven","fixed":["5.1.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:dependency-check-jenkins-plugin","purl":"pkg:maven/org.jenkins-ci.plugins/dependency-check-jenkins-plugin","source":"GHSA-mj5v-ggjc-48p5"}],"prev":{"headline":"XXE vulnerability in Jenkins pom2config Plugin","id":"CVE-2021-43576"},"products":["Jenkins OWASP Dependency-Check Plugin"],"published":"2021-11-12","related":[{"cvss_score":7.3,"headline":"Jenkins OWASP Dependency-Check Plugin has stored XSS vulnerability","id":"CVE-2024-28153","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":6.1,"headline":"Persistent XSS vulnerability in Jenkins OWASP Dependency-Check Plugin","id":"CVE-2017-1000109","kev_date_added":null,"published":"2017-10-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Jenkins project"]},"summary":"An attacker can exploit XML external entity vulnerabilities in the Jenkins OWASP Dependency-Check Plugin to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2021-43577/"}