{"answers":{"affected":"2 open source packages ship an affected version, including github.com/hyperledger/fabric. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-43669 in the wild and no public exploit code.","fix":"Upgrade github.com/hyperledger/fabric to 2.4.0 or later.","what":"CVE-2021-43669 is a high-severity denial of service vulnerability in n/a, published on 18 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-43669 and fix it if it is affected.\n\nWhat it is: CVE-2021-43669 is a high-severity denial of service vulnerability in n/a, published on 18 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-43669 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/hyperledger/fabric (Go): affected all versions; fixed in 2.4.0\n- github.com/hyperledger/fabric (Go): affected all versions; fixed in 2.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43669/ (Markdown: https://insights.sbomify.com/CVE-2021-43669/index.md)","id":"CVE-2021-43669","markdown":"https://insights.sbomify.com/CVE-2021-43669/index.md","name":"CVE-2021-43669","record":{"aliases":["GHSA-j96p-r523-8r3w"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"HyperLedger Fabric","requires_auth":"none","summary":"Attackers can cause denial of service in HyperLedger Fabric orderers by sending messages with invalid headers to the Order interface.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fabric","vendor":"linuxfoundation"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.0.1, v2.3.0. It can easily break down as many orderers as the attacker wants. This bug can be leveraged by constructing a message whose header is invalid to the interface Order. This bug has been admitted and fixed by the developers of Fabric.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HTTP Request Smuggling in github.com/hyperledger/fabric","id":"CVE-2021-43669","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2021-43673"},"packages":[{"ecosystem":"Go","fixed":["2.4.0"],"introduced":["0"],"last_affected":[],"package":"github.com/hyperledger/fabric","purl":null,"source":"GHSA-j96p-r523-8r3w"},{"ecosystem":"Go","fixed":["2.4.0"],"introduced":["0"],"last_affected":[],"package":"github.com/hyperledger/fabric","purl":"pkg:golang/github.com/hyperledger/fabric","source":"GHSA-j96p-r523-8r3w"}],"prev":{"headline":"Denial of Service in Go-Ethereum","id":"CVE-2021-43668"},"products":["n/a"],"published":"2021-11-18","related":[{"cvss_score":7.5,"headline":"NULL Pointer Dereference in HyperLedger Fabric","id":"CVE-2021-43667","kev_date_added":null,"published":"2021-11-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Attackers can cause denial of service in HyperLedger Fabric orderers by sending messages with invalid headers to the Order interface.","url":"https://insights.sbomify.com/CVE-2021-43669/"}