# CVE-2021-43669: HTTP Request Smuggling in github.com/hyperledger/fabric

> Attackers can cause denial of service in HyperLedger Fabric orderers by sending messages with invalid headers to the Order interface.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-j96p-r523-8r3w

## What is CVE-2021-43669?

CVE-2021-43669 is a high-severity denial of service vulnerability in n/a, published on 18 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability has been detected in HyperLedger Fabric v1.4.0, v2.0.0, v2.0.1, v2.3.0. It can easily break down as many orderers as the attacker wants. This bug can be leveraged by constructing a message whose header is invalid to the interface Order. This bug has been admitted and fixed by the developers of Fabric.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2021-43669?

2 open source packages ship an affected version, including github.com/hyperledger/fabric. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hyperledger/fabric` | Go | All versions | 2.4.0 |
| `github.com/hyperledger/fabric` | Go | All versions | 2.4.0 |

Products: Linuxfoundation Fabric.

## How do I fix CVE-2021-43669?

Upgrade github.com/hyperledger/fabric to 2.4.0 or later.

## Is CVE-2021-43669 being exploited?

There is no known exploitation of CVE-2021-43669 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-43667](https://insights.sbomify.com/CVE-2021-43667/): NULL Pointer Dereference in HyperLedger Fabric (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43669 and fix it if it is affected.

What it is: CVE-2021-43669 is a high-severity denial of service vulnerability in n/a, published on 18 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43669 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hyperledger/fabric (Go): affected all versions; fixed in 2.4.0
- github.com/hyperledger/fabric (Go): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43669/ (Markdown: https://insights.sbomify.com/CVE-2021-43669/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43669
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43669
- OSV: https://osv.dev/vulnerability/CVE-2021-43669

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43669/
Summaries are generated and may contain mistakes; the official description above is the record.
