# CVE-2021-4374: WordPress Automatic Plugin <= 3.53.2 - Unauthenticated Arbitrary Options Update

> Unauthenticated attackers can arbitrarily update site settings in the WordPress Automatic Plugin, potentially leading to full site compromise.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Jun 2023
- **Updated:** 8 Apr 2026
- **Also known as:** GHSA-crwv-q9pj-pwrg

## What is CVE-2021-4374?

CVE-2021-4374 is a critical missing authorization vulnerability in ValvePress WordPress Automatic Plugin, published on 7 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The WordPress Automatic Plugin for WordPress is vulnerable to arbitrary options updates in versions up to, and including, 3.53.2. This is due to missing authorization and option validation in the process_form.php file. This makes it possible for unauthenticated attackers to arbitrarily update the settings of a vulnerable site and ultimately compromise the entire site.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2021-4374?

It affects 1 product.


Products: Valvepress Wordpress Automatic Plugin.

## How do I fix CVE-2021-4374?

No fix has been published for CVE-2021-4374 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-4374 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-4374 exists.

Public exploit code:

- WordPress Plugin Automatic Config Change to RCE (metasploit)
- WordPress Automatic Plugin - Unauthenticated Options Change (nuclei): http/cves/2021/CVE-2021-4374.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4374 and fix it if it is affected.

What it is: CVE-2021-4374 is a critical missing authorization vulnerability in ValvePress WordPress Automatic Plugin, published on 7 Jun 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-4374 exists.

Affected product: ValvePress WordPress Automatic Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4374/ (Markdown: https://insights.sbomify.com/CVE-2021-4374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4374
- OSV: https://osv.dev/vulnerability/CVE-2021-4374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4374/
Summaries are generated and may contain mistakes; the official description above is the record.
