# CVE-2021-43776: XSS vulnerability in @backstage/plugin-auth-backend

> Attackers can execute XSS via malicious URLs in Backstage auth-backend, potentially stealing access tokens if CSP is disabled.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-w7fj-336r-vw49

## What is CVE-2021-43776?

CVE-2021-43776 is a high-severity cross-site scripting vulnerability in backstage, published on 26 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Backstage is an open platform for building developer portals. In affected versions the auth-backend plugin allows a malicious actor to trick another user into visiting a vulnerable URL that executes an XSS attack. This attack can potentially allow the attacker to exfiltrate access tokens or other secrets from the user's browser. The default CSP does prevent this attack, but it is expected that some deployments have these policies disabled due to incompatibilities. This is vulnerability is patched in version `0.4.9` of `@backstage/plugin-auth-backend`.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-43776?

2 open source packages ship an affected version, including @backstage/plugin-auth-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-auth-backend` | npm | All versions | 0.4.9 |
| `@backstage/plugin-auth-backend` | npm | All versions | 0.4.9 |

Products: Linuxfoundation Auth Backend.

## How do I fix CVE-2021-43776?

Upgrade @backstage/plugin-auth-backend to 0.4.9 or later.

## Is CVE-2021-43776 being exploited?

There is no known exploitation of CVE-2021-43776 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43776 and fix it if it is affected.

What it is: CVE-2021-43776 is a high-severity cross-site scripting vulnerability in backstage, published on 26 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-43776 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-auth-backend (npm): affected all versions; fixed in 0.4.9
- @backstage/plugin-auth-backend (npm): affected all versions; fixed in 0.4.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43776/ (Markdown: https://insights.sbomify.com/CVE-2021-43776/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43776
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43776
- OSV: https://osv.dev/vulnerability/CVE-2021-43776

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43776/
Summaries are generated and may contain mistakes; the official description above is the record.
