{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-43778 exists.","fix":"No fix has been published for CVE-2021-43778 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-43778 is a critical path traversal vulnerability in pluginsGLPI barcode, published on 24 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-43778 and fix it if it is affected.\n\nWhat it is: CVE-2021-43778 is a critical path traversal vulnerability in pluginsGLPI barcode, published on 24 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-43778 exists.\n\nAffected product: pluginsGLPI barcode. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43778/ (Markdown: https://insights.sbomify.com/CVE-2021-43778/index.md)","id":"CVE-2021-43778","markdown":"https://insights.sbomify.com/CVE-2021-43778/index.md","name":"CVE-2021-43778","record":{"aliases":["GHSA-2pjh-h828-wcw9"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"GLPI barcode plugin","requires_auth":"none","summary":"An attacker can exploit a path traversal vulnerability in the GLPI barcode plugin to read arbitrary files from the server.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"barcode","vendor":"glpi-project"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Barcode is a GLPI plugin for printing barcodes and QR codes. GLPI instances version 2.x prior to version 2.6.1 with the barcode plugin installed are vulnerable to a path traversal vulnerability. This issue was patched in version 2.6.1. As a workaround, delete the `front/send.php` file.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2021-11-30","github_poc":1,"max_poc_stars":3,"metasploit":0,"nuclei":1,"refs":[{"date":"2021-11-30T08:19:24Z","kind":"github_poc","ref":"https://github.com/AK-blank/CVE-2021-43778","stars":3,"title":" CVE-2021-43778 poc"},{"date":null,"kind":"nuclei","ref":"http/cves/2021/CVE-2021-43778.yaml","stars":null,"title":"GLPI plugin Barcode \u003c 2.6.1 - Path Traversal Vulnerability."}],"tier":"weaponised"},"has_fix":false,"headline":"Path traversal in GLPI barcode plugin","id":"CVE-2021-43778","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2021"},"n_packages":0,"n_references":4,"next":{"headline":"Remote Command Execution vulnerability","id":"CVE-2021-43779"},"packages":[],"prev":{"headline":"Vulnerability in Redash OAuth2 flows due to misuse of state field (should be a nonce)","id":"CVE-2021-43777"},"products":["barcode"],"published":"2021-11-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-09-08","vendors":["pluginsGLPI"]},"summary":"An attacker can exploit a path traversal vulnerability in the GLPI barcode plugin to read arbitrary files from the server.","url":"https://insights.sbomify.com/CVE-2021-43778/"}