# CVE-2021-43783: Path Traversal in @backstage/plugin-scaffolder-backend

> Attackers can write files to arbitrary paths on the host via template manipulation or user input, potentially leading to code execution.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-mg3m-f475-28hv

## What is CVE-2021-43783?

CVE-2021-43783 is a high-severity path traversal vulnerability in Linuxfoundation Backstage, published on 29 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

@backstage/plugin-scaffolder-backend is the backend for the default Backstage software templates. In affected versions a malicious actor with write access to a registered scaffolder template is able to manipulate the template in a way that writes files to arbitrary paths on the scaffolder-backend host instance. This vulnerability can in some situation also be exploited through user input when executing a template, meaning you do not need write access to the templates. This method will not allow the attacker to control the contents of the injected file however, unless the template is also crafted in a specific way that gives control of the file contents. This vulnerability is fixed in version `0.15.14` of the `@backstage/plugin-scaffolder-backend`. This attack is mitigated by restricting access and requiring reviews when registering or modifying scaffolder templates.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-43783?

2 open source packages ship an affected version, including @backstage/plugin-scaffolder-backend. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 0.15.14 |
| `@backstage/plugin-scaffolder-backend` | npm | All versions | 0.15.14 |

Products: Linuxfoundation Backstage.

## How do I fix CVE-2021-43783?

Upgrade @backstage/plugin-scaffolder-backend to 0.15.14 or later.

## Is CVE-2021-43783 being exploited?

There is no known exploitation of CVE-2021-43783 in the wild and no public exploit code.

## Other vulnerabilities in Linuxfoundation Backstage

- [CVE-2026-106501](https://insights.sbomify.com/CVE-2026-106501/): Backstage: Sensitive information exposure in Scaffolder (critical 9.6)
- [CVE-2026-106558](https://insights.sbomify.com/CVE-2026-106558/): Backstage: Improper validation of TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-88064](https://insights.sbomify.com/CVE-2026-88064/): Backstage: Improper input validation in TechDocs MkDocs configuration (high 8.8)
- [CVE-2026-106459](https://insights.sbomify.com/CVE-2026-106459/): Backstage: Improper input validation in Sentry scaffolder actions (high 8.5)
- [CVE-2026-106486](https://insights.sbomify.com/CVE-2026-106486/): Backstage: Improper filesystem validation in Bitbucket pull-request scaffolder actions (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43783 and fix it if it is affected.

What it is: CVE-2021-43783 is a high-severity path traversal vulnerability in Linuxfoundation Backstage, published on 29 Nov 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43783 in the wild and no public exploit code.

Affected packages and fixed versions:
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 0.15.14
- @backstage/plugin-scaffolder-backend (npm): affected all versions; fixed in 0.15.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43783/ (Markdown: https://insights.sbomify.com/CVE-2021-43783/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43783
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43783
- OSV: https://osv.dev/vulnerability/CVE-2021-43783

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43783/
Summaries are generated and may contain mistakes; the official description above is the record.
