{"answers":{"affected":"2 open source packages ship an affected version, including @joeattardi/emoji-button. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-43785 in the wild and no public exploit code.","fix":"Upgrade @joeattardi/emoji-button to 4.6.2 or later.","what":"CVE-2021-43785 is a high-severity cross-site scripting vulnerability in joeattardi emoji-button, published on 26 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-43785 and fix it if it is affected.\n\nWhat it is: CVE-2021-43785 is a high-severity cross-site scripting vulnerability in joeattardi emoji-button, published on 26 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-43785 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @joeattardi/emoji-button (npm): affected all versions; fixed in 4.6.2\n- @joeattardi/emoji-button (npm): affected all versions; fixed in 4.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43785/ (Markdown: https://insights.sbomify.com/CVE-2021-43785/index.md)","id":"CVE-2021-43785","markdown":"https://insights.sbomify.com/CVE-2021-43785/index.md","name":"CVE-2021-43785","record":{"aliases":["GHSA-f34m-x9pj-62vq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript emoji picker","requires_auth":"none","summary":"Attackers can inject malicious scripts via custom emoji URLs or i18n strings, leading to code execution in the browser.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"emoji_button","vendor":"emoji_button_project"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"@joeattardi/emoji-button is a Vanilla JavaScript emoji picker component. In affected versions there are two vectors for XSS attacks: a URL for a custom emoji, and an i18n string. In both of these cases, a value can be crafted such that it can insert a `script` tag into the page and execute malicious code.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross Site Scripting Vulnerability in @joeattardi/emoji-button","id":"CVE-2021-43785","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"API token verification can be bypassed","id":"CVE-2021-43786"},"packages":[{"ecosystem":"npm","fixed":["4.6.2"],"introduced":["0"],"last_affected":[],"package":"@joeattardi/emoji-button","purl":null,"source":"GHSA-f34m-x9pj-62vq"},{"ecosystem":"npm","fixed":["4.6.2"],"introduced":["0"],"last_affected":[],"package":"@joeattardi/emoji-button","purl":"pkg:npm/%40joeattardi/emoji-button","source":"GHSA-f34m-x9pj-62vq"}],"prev":{"headline":"Overflow in netlink bytemsg length field allows attacker to override netlink-based container configuration","id":"CVE-2021-43784"},"products":["emoji-button"],"published":"2021-11-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["joeattardi"]},"summary":"Attackers can inject malicious scripts via custom emoji URLs or i18n strings, leading to code execution in the browser.","url":"https://insights.sbomify.com/CVE-2021-43785/"}