# CVE-2021-43786: API token verification can be bypassed

> Attackers can bypass API token verification to gain unauthorized master token access in NodeBB forum software.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-hf2m-j98r-4fqw

## What is CVE-2021-43786?

CVE-2021-43786 is a critical authentication bypass vulnerability in NodeBB, published on 29 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Nodebb is an open source Node.js based forum software. In affected versions incorrect logic present in the token verification step unintentionally allowed master token access to the API. The vulnerability has been patch as of v1.18.5. Users are advised to upgrade as soon as possible.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2021-43786?

2 open source packages ship an affected version, including nodebb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodebb` | npm | From 1.15.0 | 1.18.5 |
| `nodebb` | npm | From 1.15.0 | 1.18.5 |

Products: Nodebb Nodebb.

## How do I fix CVE-2021-43786?

Upgrade nodebb to 1.18.5 or later.

## Is CVE-2021-43786 being exploited?

There is no known exploitation of CVE-2021-43786 in the wild and no public exploit code.

## Other vulnerabilities in NodeBB

- [CVE-2023-26045](https://insights.sbomify.com/CVE-2023-26045/): NodeBB vulnerable to path traversal and code execution via prototype vulnerability (critical 10.0)
- [CVE-2020-15149](https://insights.sbomify.com/CVE-2020-15149/): Account takeover in NodeBB (critical 9.9)
- [CVE-2023-43187](https://insights.sbomify.com/CVE-2023-43187/): Code injection in n/a (critical 9.8)
- [CVE-2022-46164](https://insights.sbomify.com/CVE-2022-46164/): Account takeover via prototype vulnerability (critical 9.4)
- [CVE-2022-36045](https://insights.sbomify.com/CVE-2022-36045/): Account takeover via cryptographically weak PRNG in NodeBB Forum (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43786 and fix it if it is affected.

What it is: CVE-2021-43786 is a critical authentication bypass vulnerability in NodeBB, published on 29 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43786 in the wild and no public exploit code.

Affected packages and fixed versions:
- nodebb (npm): affected from 1.15.0; fixed in 1.18.5
- nodebb (npm): affected from 1.15.0; fixed in 1.18.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43786/ (Markdown: https://insights.sbomify.com/CVE-2021-43786/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43786
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43786
- OSV: https://osv.dev/vulnerability/CVE-2021-43786

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43786/
Summaries are generated and may contain mistakes; the official description above is the record.
