# CVE-2021-43797: HTTP fails to validate against control chars in header names which may lead to HTTP request smuggling

> Netty fails to validate control characters in HTTP header names, allowing HTTP request smuggling when used as a proxy.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Dec 2021
- **Updated:** 8 Oct 2026
- **Also known as:** CLEANSTART-2026-HO82916, CLEANSTART-2026-OX13764, CLSA-2026-1793139574, DEBIAN-CVE-2021-43797, GHSA-wx5j-54mm-rqqq, OESA-2021-1472, OESA-2022-1930, SUSE-SU-2022:2047-1, UBUNTU-CVE-2021-43797, openSUSE-SU-2024:11743-1, openSUSE-SU-2024:11981-1

## What is CVE-2021-43797?

CVE-2021-43797 is a medium-severity vulnerability in Debian Debian Linux, published on 9 Dec 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. Netty prior to version 4.1.71.Final skips control chars when they are present at the beginning / end of the header name. It should instead fail fast as these are not allowed by the spec and could lead to HTTP request smuggling. Failing to do the validation might cause netty to "sanitize" header names before it forward these to another remote system when used as proxy. This remote system can't see the invalid usage anymore, and therefore does not do the validation itself. Users should upgrade to version 4.1.71.Final.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2021-43797?

6 open source packages ship an affected version, including io.netty:netty, io.netty:netty-codec-http and org.jboss.netty:netty. It affects 18 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty` | Maven | All versions | None |
| `io.netty:netty` | Maven | All versions | None |
| `io.netty:netty-codec-http` | Maven | From 4.0.0 | 4.1.71.Final |
| `io.netty:netty-codec-http` | Maven | From 4.0.0 | 4.1.71.Final |
| `org.jboss.netty:netty` | Maven | All versions | None |
| `org.jboss.netty:netty` | Maven | All versions | None |
| `netty3` | SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 3.10.6-150200.3.3.2 |
| `netty3` | SUSE:Linux Enterprise Module for Development Tools 15 SP4 | All versions | 3.10.6-150200.3.3.2 |
| `netty3` | openSUSE:Leap 15.3 | All versions | 3.10.6-150200.3.3.2 |
| `netty3` | openSUSE:Leap 15.4 | All versions | 3.10.6-150200.3.3.2 |
| `netty` | openSUSE:Tumbleweed | All versions | 4.1.72-1.1 |
| `netty3` | openSUSE:Tumbleweed | All versions | 3.10.6-9.1 |

Products: Debian Debian Linux, Netapp Oncommand Workflow Automation, Netapp Snapcenter, Netty Netty, Oracle Banking Deposits and Lines of Credit Servicing, Oracle Banking Party Management, Oracle Banking Platform, Oracle Coherence, Oracle Communications Cloud Native Core Binding Support Function, Oracle Communications Cloud Native Core Network Slice Selection Function, Oracle Communications Cloud Native Core Policy, Oracle Communications Cloud Native Core Security Edge Protection Proxy, Oracle Communications Cloud Native Core Unified Data Repository, Oracle Communications Design Studio, Oracle Communications Instant Messaging Server, Oracle Helidon, Oracle Peoplesoft Enterprise Peopletools, Quarkus Quarkus.

## How do I fix CVE-2021-43797?

Upgrade to a fixed version.

## Is CVE-2021-43797 being exploited?

There is no known exploitation of CVE-2021-43797 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43797 and fix it if it is affected.

What it is: CVE-2021-43797 is a medium-severity vulnerability in Debian Debian Linux, published on 9 Dec 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-43797 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty (Maven): affected all versions; no fix listed
- io.netty:netty (Maven): affected all versions; no fix listed
- io.netty:netty-codec-http (Maven): affected from 4.0.0; fixed in 4.1.71.Final
- io.netty:netty-codec-http (Maven): affected from 4.0.0; fixed in 4.1.71.Final
- org.jboss.netty:netty (Maven): affected all versions; no fix listed
- org.jboss.netty:netty (Maven): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43797/ (Markdown: https://insights.sbomify.com/CVE-2021-43797/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43797
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43797
- OSV: https://osv.dev/vulnerability/CVE-2021-43797

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43797/
Summaries are generated and may contain mistakes; the official description above is the record.
