{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-43802 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-43802 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-43802 is a critical vulnerability in etherpad-lite, published on 9 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-43802 and fix it if it is affected.\n\nWhat it is: CVE-2021-43802 is a critical vulnerability in etherpad-lite, published on 9 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-43802 in the wild and no public exploit code.\n\nAffected product: etherpad-lite. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43802/ (Markdown: https://insights.sbomify.com/CVE-2021-43802/index.md)","id":"CVE-2021-43802","markdown":"https://insights.sbomify.com/CVE-2021-43802/index.md","name":"CVE-2021-43802","record":{"aliases":["GHSA-w3g3-qf3g-2mqc"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Etherpad collaborative editor","requires_auth":"low_privilege","summary":"Attackers can escalate to admin and execute arbitrary code via malicious imports if session state is deleted, requiring specific cleanup configurations.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"etherpad","vendor":"etherpad"}],"cvss":{"score":9.9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-790","name":"Improper Filtering of Special Elements"},{"id":"CWE-1287","name":"Improper Validation of Specified Type of Input"}],"description":"Etherpad is a real-time collaborative editor. In versions prior to 1.8.16, an attacker can craft an `*.etherpad` file that, when imported, might allow the attacker to gain admin privileges for the Etherpad instance. This, in turn, can be used to install a malicious Etherpad plugin that can execute arbitrary code (including system commands). To gain privileges, the attacker must be able to trigger deletion of `express-session` state or wait for old `express-session` state to be cleaned up. Core Etherpad does not delete any `express-session` state, so the only known attacks require either a plugin that can delete session state or a custom cleanup process (such as a cron job that deletes old `sessionstorage:*` records). The problem has been fixed in version 1.8.16. If users cannot upgrade to 1.8.16 or install patches manually, several workarounds are available. Users may configure their reverse proxies to reject requests to `/p/*/import`, which will block all imports, not just `*.etherpad` imports; limit all users to read-only access; and/or prevent the reuse of `express_sid` cookie values that refer to deleted express-session state. More detailed information and general mitigation strategies may be found in the GitHub Security Advisory.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Admin privilege escalation and arbitrary code execution via malicious *.etherpad imports","id":"CVE-2021-43802","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2021"},"n_packages":0,"n_references":4,"next":{"headline":"Unexpected server crash in Next.js","id":"CVE-2021-43803"},"packages":[],"prev":{"headline":"Uncaught Exception in mercurius","id":"CVE-2021-43801"},"products":["etherpad-lite"],"published":"2021-12-09","related":[{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2018-9326","kev_date_added":null,"published":"2018-04-07"},{"cvss_score":9.8,"headline":"Etherpad Lite Access Restriction Bypass","id":"CVE-2018-6835","kev_date_added":null,"published":"2018-02-08"},{"cvss_score":8.1,"headline":"Code injection in n/a","id":"CVE-2018-9327","kev_date_added":null,"published":"2018-04-07"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2020-22781","kev_date_added":null,"published":"2021-04-28"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2020-22782","kev_date_added":null,"published":"2021-04-28"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2020-22785","kev_date_added":null,"published":"2021-04-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["ether"]},"summary":"Attackers can escalate to admin and execute arbitrary code via malicious imports if session state is deleted, requiring specific cleanup configurations.","url":"https://insights.sbomify.com/CVE-2021-43802/"}