# CVE-2021-43802: Admin privilege escalation and arbitrary code execution via malicious *.etherpad imports

> Attackers can escalate to admin and execute arbitrary code via malicious imports if session state is deleted, requiring specific cleanup configurations.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-w3g3-qf3g-2mqc

## What is CVE-2021-43802?

CVE-2021-43802 is a critical vulnerability in etherpad-lite, published on 9 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Etherpad is a real-time collaborative editor. In versions prior to 1.8.16, an attacker can craft an `*.etherpad` file that, when imported, might allow the attacker to gain admin privileges for the Etherpad instance. This, in turn, can be used to install a malicious Etherpad plugin that can execute arbitrary code (including system commands). To gain privileges, the attacker must be able to trigger deletion of `express-session` state or wait for old `express-session` state to be cleaned up. Core Etherpad does not delete any `express-session` state, so the only known attacks require either a plugin that can delete session state or a custom cleanup process (such as a cron job that deletes old `sessionstorage:*` records). The problem has been fixed in version 1.8.16. If users cannot upgrade to 1.8.16 or install patches manually, several workarounds are available. Users may configure their reverse proxies to reject requests to `/p/*/import`, which will block all imports, not just `*.etherpad` imports; limit all users to read-only access; and/or prevent the reuse of `express_sid` cookie values that refer to deleted express-session state. More detailed information and general mitigation strategies may be found in the GitHub Security Advisory.

Weakness: CWE-20 (Improper Input Validation), CWE-790 (Improper Filtering of Special Elements), CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2021-43802?

It affects 1 product.


Products: Etherpad Etherpad.

## How do I fix CVE-2021-43802?

No fix has been published for CVE-2021-43802 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-43802 being exploited?

There is no known exploitation of CVE-2021-43802 in the wild and no public exploit code.

## Other vulnerabilities in etherpad-lite

- [CVE-2018-9326](https://insights.sbomify.com/CVE-2018-9326/): Code injection in n/a (critical 9.8)
- [CVE-2018-6835](https://insights.sbomify.com/CVE-2018-6835/): Etherpad Lite Access Restriction Bypass (critical 9.8)
- [CVE-2018-9327](https://insights.sbomify.com/CVE-2018-9327/): Code injection in n/a (high 8.1)
- [CVE-2020-22781](https://insights.sbomify.com/CVE-2020-22781/): Denial of service in n/a (high 7.5)
- [CVE-2020-22782](https://insights.sbomify.com/CVE-2020-22782/): Denial of service in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43802 and fix it if it is affected.

What it is: CVE-2021-43802 is a critical vulnerability in etherpad-lite, published on 9 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43802 in the wild and no public exploit code.

Affected product: etherpad-lite. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43802/ (Markdown: https://insights.sbomify.com/CVE-2021-43802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43802
- OSV: https://osv.dev/vulnerability/CVE-2021-43802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43802/
Summaries are generated and may contain mistakes; the official description above is the record.
