{"answers":{"affected":"4 open source packages ship an affected version, including next. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-43803 in the wild and no public exploit code.","fix":"Upgrade next to a fixed version for your release line: 11.1.3 or 12.0.5.","what":"CVE-2021-43803 is a high-severity denial of service vulnerability in Vercel Next.js, published on 9 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-43803 and fix it if it is affected.\n\nWhat it is: CVE-2021-43803 is a high-severity denial of service vulnerability in Vercel Next.js, published on 9 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-43803 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- next (npm): affected from 0.9.9; fixed in 11.1.3\n- next (npm): affected from 0.9.9; fixed in 11.1.3\n- next (npm): affected from 12.0.0; fixed in 12.0.5\n- next (npm): affected from 12.0.0; fixed in 12.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43803/ (Markdown: https://insights.sbomify.com/CVE-2021-43803/index.md)","id":"CVE-2021-43803","markdown":"https://insights.sbomify.com/CVE-2021-43803/index.md","name":"CVE-2021-43803","record":{"aliases":["CLEANSTART-2026-XA75474","GHSA-25mp-g6fv-mqxx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Next.js framework","requires_auth":"none","summary":"Attackers can crash Next.js servers by sending malformed URLs, affecting deployments using specific Node.js versions and custom servers.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"next.js","vendor":"vercel"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Next.js is a React framework. In versions of Next.js prior to 12.0.5 or 11.1.3, invalid or malformed URLs could lead to a server crash. In order to be affected by this issue, the deployment must use Next.js versions above 11.1.0 and below 12.0.5, Node.js above 15.0.0, and next start or a custom server. Deployments on Vercel are not affected, along with similar environments where invalid requests are filtered before reaching Next.js. Versions 12.0.5 and 11.1.3 contain patches for this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unexpected server crash in Next.js","id":"CVE-2021-43803","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"vercel:next.js","products":["vercel:next.js"],"type":"denial_of_service","year":"2021"},"n_packages":4,"n_references":5,"next":{"headline":"Out-of-bounds read when parsing RTCP BYE message in PJSIP","id":"CVE-2021-43804"},"packages":[{"ecosystem":"npm","fixed":["11.1.3"],"introduced":["0.9.9"],"last_affected":[],"package":"next","purl":null,"source":"GHSA-25mp-g6fv-mqxx"},{"ecosystem":"npm","fixed":["11.1.3"],"introduced":["0.9.9"],"last_affected":[],"package":"next","purl":"pkg:npm/next","source":"GHSA-25mp-g6fv-mqxx"},{"ecosystem":"npm","fixed":["12.0.5"],"introduced":["12.0.0"],"last_affected":[],"package":"next","purl":null,"source":"GHSA-25mp-g6fv-mqxx"},{"ecosystem":"npm","fixed":["12.0.5"],"introduced":["12.0.0"],"last_affected":[],"package":"next","purl":"pkg:npm/next","source":"GHSA-25mp-g6fv-mqxx"}],"prev":{"headline":"Admin privilege escalation and arbitrary code execution via malicious *.etherpad imports","id":"CVE-2021-43802"},"products":["next.js"],"published":"2021-12-09","related":[{"cvss_score":9.1,"headline":"Authorization Bypass in Next.js Middleware","id":"CVE-2025-29927","kev_date_added":null,"published":"2025-03-21"},{"cvss_score":8.6,"headline":"Next.js: Server-side request forgery in applications using WebSocket upgrades","id":"CVE-2026-44578","kev_date_added":null,"published":"2026-05-13"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in Image Optimization","id":"CVE-2026-94483","kev_date_added":null,"published":"2026-10-02"},{"cvss_score":8.3,"headline":"Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale","id":"CVE-2026-64642","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname","id":"CVE-2026-64645","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.3,"headline":"Next.js: Server-Side Request Forgery in Server Actions on Custom Servers","id":"CVE-2026-64649","kev_date_added":null,"published":"2026-07-27"},{"cvss_score":8.2,"headline":"Next.js: Denial of Service in App Router using Server Actions","id":"CVE-2026-64641","kev_date_added":null,"published":"2026-07-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["vercel"]},"summary":"Attackers can crash Next.js servers by sending malformed URLs, affecting deployments using specific Node.js versions and custom servers.","url":"https://insights.sbomify.com/CVE-2021-43803/"}