# CVE-2021-43803: Unexpected server crash in Next.js

> Attackers can crash Next.js servers by sending malformed URLs, affecting deployments using specific Node.js versions and custom servers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** CLEANSTART-2026-XA75474, GHSA-25mp-g6fv-mqxx

## What is CVE-2021-43803?

CVE-2021-43803 is a high-severity denial of service vulnerability in Vercel Next.js, published on 9 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Next.js is a React framework. In versions of Next.js prior to 12.0.5 or 11.1.3, invalid or malformed URLs could lead to a server crash. In order to be affected by this issue, the deployment must use Next.js versions above 11.1.0 and below 12.0.5, Node.js above 15.0.0, and next start or a custom server. Deployments on Vercel are not affected, along with similar environments where invalid requests are filtered before reaching Next.js. Versions 12.0.5 and 11.1.3 contain patches for this issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-43803?

4 open source packages ship an affected version, including next. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next` | npm | From 0.9.9 | 11.1.3 |
| `next` | npm | From 0.9.9 | 11.1.3 |
| `next` | npm | From 12.0.0 | 12.0.5 |
| `next` | npm | From 12.0.0 | 12.0.5 |

Products: Vercel Next.js.

## How do I fix CVE-2021-43803?

Upgrade next to a fixed version for your release line: 11.1.3 or 12.0.5.

## Is CVE-2021-43803 being exploited?

There is no known exploitation of CVE-2021-43803 in the wild and no public exploit code.

## Other vulnerabilities in Vercel Next.js

- [CVE-2025-29927](https://insights.sbomify.com/CVE-2025-29927/): Authorization Bypass in Next.js Middleware (critical 9.1)
- [CVE-2026-44578](https://insights.sbomify.com/CVE-2026-44578/): Next.js: Server-side request forgery in applications using WebSocket upgrades (high 8.6)
- [CVE-2026-94483](https://insights.sbomify.com/CVE-2026-94483/): Next.js: Server-Side Request Forgery in Image Optimization (high 8.3)
- [CVE-2026-64642](https://insights.sbomify.com/CVE-2026-64642/): Next.js: Middleware / Proxy bypass in App Router applications using Turbopack and single locale (high 8.3)
- [CVE-2026-64645](https://insights.sbomify.com/CVE-2026-64645/): Next.js: Server-Side Request Forgery in rewrites via attacker-controlled destination hostname (high 8.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43803 and fix it if it is affected.

What it is: CVE-2021-43803 is a high-severity denial of service vulnerability in Vercel Next.js, published on 9 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43803 in the wild and no public exploit code.

Affected packages and fixed versions:
- next (npm): affected from 0.9.9; fixed in 11.1.3
- next (npm): affected from 0.9.9; fixed in 11.1.3
- next (npm): affected from 12.0.0; fixed in 12.0.5
- next (npm): affected from 12.0.0; fixed in 12.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43803/ (Markdown: https://insights.sbomify.com/CVE-2021-43803/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43803
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43803
- OSV: https://osv.dev/vulnerability/CVE-2021-43803

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43803/
Summaries are generated and may contain mistakes; the official description above is the record.
