# CVE-2021-43805: ReDos vulnerability on guest checkout email validation

> Attackers can cause denial of service in Solidus guest checkout via exponential backtracking in email validation regex.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-qxmr-qxh6-2cc9

## What is CVE-2021-43805?

CVE-2021-43805 is a high-severity denial of service vulnerability in solidusio solidus, published on 7 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Solidus is a free, open-source ecommerce platform built on Rails. Versions of Solidus prior to 3.1.4, 3.0.4, and 2.11.13 have a denial of service vulnerability that could be exploited during a guest checkout. The regular expression used to validate a guest order's email was subject to exponential backtracking through a fragment like `a.a.` Versions 3.1.4, 3.0.4, and 2.11.13 have been patched to use a different regular expression. The maintainers added a check for email addresses that are no longer valid that will print information about any affected orders that exist. If a prompt upgrade is not an option, a workaround is available. It is possible to edit the file `config/application.rb` manually (with code provided by the maintainers in the GitHub Security Advisory) to check email validity.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2021-43805?

6 open source packages ship an affected version, including solidus_core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `solidus_core` | RubyGems | All versions | 2.11.13 |
| `solidus_core` | RubyGems | All versions | 2.11.13 |
| `solidus_core` | RubyGems | From 3.0.0 | 3.0.4 |
| `solidus_core` | RubyGems | From 3.0.0 | 3.0.4 |
| `solidus_core` | RubyGems | From 3.1.0 | 3.1.4 |
| `solidus_core` | RubyGems | From 3.1.0 | 3.1.4 |

Products: Nebulab Solidus.

## How do I fix CVE-2021-43805?

Upgrade solidus_core to a fixed version for your release line: 2.11.13, 3.0.4 or 3.1.4.

## Is CVE-2021-43805 being exploited?

There is no known exploitation of CVE-2021-43805 in the wild and no public exploit code.

## Other vulnerabilities in solidusio solidus

- [CVE-2021-43846](https://insights.sbomify.com/CVE-2021-43846/): CSRF forgery protection bypass for Spree::OrdersController#populate (medium 5.3)
- [CVE-2020-15109](https://insights.sbomify.com/CVE-2020-15109/): Ability to change order address without triggering address validations in solidus (medium 5.3)
- [CVE-2022-31000](https://insights.sbomify.com/CVE-2022-31000/): CSRF allows attacker to finalize/unfinalize order adjustments in solidus_backend (low 2.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43805 and fix it if it is affected.

What it is: CVE-2021-43805 is a high-severity denial of service vulnerability in solidusio solidus, published on 7 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43805 in the wild and no public exploit code.

Affected packages and fixed versions:
- solidus_core (RubyGems): affected all versions; fixed in 2.11.13
- solidus_core (RubyGems): affected all versions; fixed in 2.11.13
- solidus_core (RubyGems): affected from 3.0.0; fixed in 3.0.4
- solidus_core (RubyGems): affected from 3.0.0; fixed in 3.0.4
- solidus_core (RubyGems): affected from 3.1.0; fixed in 3.1.4
- solidus_core (RubyGems): affected from 3.1.0; fixed in 3.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43805/ (Markdown: https://insights.sbomify.com/CVE-2021-43805/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43805
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43805
- OSV: https://osv.dev/vulnerability/CVE-2021-43805

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43805/
Summaries are generated and may contain mistakes; the official description above is the record.
