CVE-2021-43807 HTTP Method Spoofing in Opencast

High 7.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2021-43807?

CVE-2021-43807 is a high-severity vulnerability in opencast, published on 14 Dec 2021.

Official description

Opencast is an Open Source Lecture Capture & Video Management for Education. Opencast versions prior to 9.10 allow HTTP method spoofing, allowing to change the assumed HTTP method via URL parameter. This allows attackers to turn HTTP GET requests into PUT requests or an HTTP form to send DELETE requests. This bypasses restrictions otherwise put on these types of requests and aids in cross-site request forgery (CSRF) attacks, which would otherwise not be possible. The vulnerability allows attackers to craft links or forms which may change the server state. This issue is fixed in Opencast 9.10 and 10.0. You can mitigate the problem by setting the `SameSite=Strict` attribute for your cookies. If this is a viable option for you depends on your integrations. We strongly recommend updating in any case.

Weakness: CWE-290

Which versions are affected by CVE-2021-43807?

2 open source packages ship an affected version, including org.opencastproject:opencast-common. It affects 1 product.

PackageAffectedFixed in
org.opencastproject:opencast-common MavenAll versions9.10
org.opencastproject:opencast-common MavenAll versions9.10

Products include Apereo Opencast.

How do I fix CVE-2021-43807?

Upgrade org.opencastproject:opencast-common to 9.10 or later.

Is CVE-2021-43807 being exploited?

There is no known exploitation of CVE-2021-43807 in the wild and no public exploit code.

Sources

Also known as GHSA-j4mm-7pj3-jf7v.

Is CVE-2021-43807 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free