{"answers":{"affected":"3 open source packages ship an affected version, including sockeye. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-43811 in the wild and no public exploit code.","fix":"Upgrade sockeye to 2.3.24 or later.","what":"CVE-2021-43811 is a high-severity code injection vulnerability in awslabs sockeye, published on 8 Dec 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2021-43811 and fix it if it is affected.\n\nWhat it is: CVE-2021-43811 is a high-severity code injection vulnerability in awslabs sockeye, published on 8 Dec 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2021-43811 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- sockeye (PyPI): affected all versions; fixed in 2.3.24\n- sockeye (PyPI): affected all versions; fixed in 2.3.24\n- sockeye (PyPI): affected all versions; fixed in 2.3.24\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43811/ (Markdown: https://insights.sbomify.com/CVE-2021-43811/index.md)","id":"CVE-2021-43811","markdown":"https://insights.sbomify.com/CVE-2021-43811/index.md","name":"CVE-2021-43811","record":{"aliases":["GHSA-ggmr-44cv-24pm","PYSEC-2021-848"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Neural Machine Translation library","requires_auth":"none","summary":"Attackers can execute arbitrary code by tricking users into running a Sockeye model with a maliciously crafted YAML configuration file.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"sockeye","vendor":"amazon"}],"cvss":{"score":7.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Sockeye is an open-source sequence-to-sequence framework for Neural Machine Translation built on PyTorch. Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files. An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally. The issue is fixed in version 2.3.24.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":"2022-08-21","github_poc":1,"max_poc_stars":2,"metasploit":0,"nuclei":0,"refs":[{"date":"2022-08-21T08:44:31Z","kind":"github_poc","ref":"https://github.com/s-index/CVE-2021-43811","stars":2,"title":"awslabs/sockeye Code injection via unsafe YAML loading CVE-2021-43811"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Code injection via unsafe YAML loading","id":"CVE-2021-43811","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2021"},"n_packages":3,"n_references":3,"next":{"headline":"Open redirect in nextjs-auth0","id":"CVE-2021-43812"},"packages":[{"ecosystem":"PyPI","fixed":["2.3.24"],"introduced":["0"],"last_affected":[],"package":"sockeye","purl":null,"source":"GHSA-ggmr-44cv-24pm"},{"ecosystem":"PyPI","fixed":["2.3.24"],"introduced":["0"],"last_affected":[],"package":"sockeye","purl":"pkg:pypi/sockeye","source":"GHSA-ggmr-44cv-24pm"},{"ecosystem":"PyPI","fixed":["2.3.24"],"introduced":["0"],"last_affected":[],"package":"sockeye","purl":"pkg:pypi/sockeye","source":"PYSEC-2021-848"}],"prev":{"headline":"Cross-site Scripting (XSS) when redirect an url","id":"CVE-2021-43810"},"products":["sockeye"],"published":"2021-12-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["awslabs"]},"summary":"Attackers can execute arbitrary code by tricking users into running a Sockeye model with a maliciously crafted YAML configuration file.","url":"https://insights.sbomify.com/CVE-2021-43811/"}