# CVE-2021-43811: Code injection via unsafe YAML loading

> Attackers can execute arbitrary code by tricking users into running a Sockeye model with a maliciously crafted YAML configuration file.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-ggmr-44cv-24pm, PYSEC-2021-848

## What is CVE-2021-43811?

CVE-2021-43811 is a high-severity code injection vulnerability in awslabs sockeye, published on 8 Dec 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Sockeye is an open-source sequence-to-sequence framework for Neural Machine Translation built on PyTorch. Sockeye uses YAML to store model and data configurations on disk. Versions below 2.3.24 use unsafe YAML loading, which can be made to execute arbitrary code embedded in config files. An attacker can add malicious code to the config file of a trained model and attempt to convince users to download and run it. If users run the model, the embedded code will run locally. The issue is fixed in version 2.3.24.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2021-43811?

3 open source packages ship an affected version, including sockeye. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sockeye` | PyPI | All versions | 2.3.24 |
| `sockeye` | PyPI | All versions | 2.3.24 |
| `sockeye` | PyPI | All versions | 2.3.24 |

Products: Amazon Sockeye.

## How do I fix CVE-2021-43811?

Upgrade sockeye to 2.3.24 or later.

## Is CVE-2021-43811 being exploited?

There is no known exploitation of CVE-2021-43811 in the wild and no public exploit code.

Public exploit code:

- awslabs/sockeye Code injection via unsafe YAML loading CVE-2021-43811 (github_poc): https://github.com/s-index/CVE-2021-43811

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43811 and fix it if it is affected.

What it is: CVE-2021-43811 is a high-severity code injection vulnerability in awslabs sockeye, published on 8 Dec 2021. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-43811 in the wild and no public exploit code.

Affected packages and fixed versions:
- sockeye (PyPI): affected all versions; fixed in 2.3.24
- sockeye (PyPI): affected all versions; fixed in 2.3.24
- sockeye (PyPI): affected all versions; fixed in 2.3.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43811/ (Markdown: https://insights.sbomify.com/CVE-2021-43811/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43811
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43811
- OSV: https://osv.dev/vulnerability/CVE-2021-43811

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43811/
Summaries are generated and may contain mistakes; the official description above is the record.
