# CVE-2021-43813: Directory Traversal in Grafana

> Authenticated attackers can read arbitrary markdown files via directory traversal in Grafana, requiring an upgrade to patched versions.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** ALSA-2022:1781, BIT-grafana-2021-43813, GHSA-c3q8-26ph-9g2q, OESA-2021-1470, RHSA-2022:1781, RLSA-2022:1781, UBUNTU-CVE-2021-43813, openSUSE-SU-2024:11694-1

## What is CVE-2021-43813?

CVE-2021-43813 is a medium-severity path traversal vulnerability in Grafana Grafana, published on 10 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Grafana is an open-source platform for monitoring and observability. Grafana prior to versions 8.3.2 and 7.5.12 contains a directory traversal vulnerability for fully lowercase or fully uppercase .md files. The vulnerability is limited in scope, and only allows access to files with the extension .md to authenticated users only. Grafana Cloud instances have not been affected by the vulnerability. Users should upgrade to patched versions 8.3.2 or 7.5.12. For users who cannot upgrade, running a reverse proxy in front of Grafana that normalizes the PATH of the request will mitigate the vulnerability. The proxy will have to also be able to handle url encoded paths. Alternatively, for fully lowercase or fully uppercase .md files, users can block /api/plugins/.*/markdown/.* without losing any functionality beyond inlined plugin help text.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-43813?

1 open source package ship an affected version, including grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grafana` | Bitnami | From 5.0.0 | 7.5.12, 8.3.2 |
| `grafana` | AlmaLinux:8 | All versions | 7.5.11-2.el8 |
| `grafana` | Red Hat:enterprise_linux:8::appstream | All versions | 0:7.5.11-2.el8 |
| `grafana-debuginfo` | Red Hat:enterprise_linux:8::appstream | All versions | 0:7.5.11-2.el8 |
| `grafana` | Rocky Linux:8 | All versions | 0:7.5.11-2.el8 |
| `grafana` | openSUSE:Tumbleweed | All versions | 7.5.12-1.1 |

Products: Grafana Grafana.

## How do I fix CVE-2021-43813?

Upgrade grafana to a fixed version for your release line: 7.5.12 or 8.3.2.

## Is CVE-2021-43813 being exploited?

There is no known exploitation of CVE-2021-43813 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43813 and fix it if it is affected.

What it is: CVE-2021-43813 is a medium-severity path traversal vulnerability in Grafana Grafana, published on 10 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43813 in the wild and no public exploit code.

Affected packages and fixed versions:
- grafana (Bitnami): affected from 5.0.0; fixed in 7.5.12, 8.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43813/ (Markdown: https://insights.sbomify.com/CVE-2021-43813/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43813
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43813
- OSV: https://osv.dev/vulnerability/CVE-2021-43813

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43813/
Summaries are generated and may contain mistakes; the official description above is the record.
