# CVE-2021-43816: Improper Preservation of Permissions in containerd

> An unprivileged container can read and write privileged host files via hostPath mounts on SELinux systems, requiring an upgrade to containerd.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jan 2022
- **Updated:** 22 Apr 2025
- **Also known as:** CLEANSTART-2025-GQ42610, DEBIAN-CVE-2021-43816, GHSA-mvff-h3cj-wj9c, GO-2022-0278, MGASA-2022-0071, UBUNTU-CVE-2021-43816

## What is CVE-2021-43816?

CVE-2021-43816 is a high-severity vulnerability in Fedoraproject Fedora, published on 5 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

containerd is an open source container runtime. On installations using SELinux, such as EL8 (CentOS, RHEL), Fedora, or SUSE MicroOS, with containerd since v1.5.0-beta.0 as the backing container runtime interface (CRI), an unprivileged pod scheduled to the node may bind mount, via hostPath volume, any privileged, regular file on disk for complete read/write access (sans delete). Such is achieved by placing the in-container location of the hostPath volume mount at either `/etc/hosts`, `/etc/hostname`, or `/etc/resolv.conf`. These locations are being relabeled indiscriminately to match the container process-label which effectively elevates permissions for savvy containers that would not normally be able to access privileged host files. This issue has been resolved in version 1.5.9. Users are advised to upgrade as soon as possible.

Weakness: CWE-281 (Improper Preservation of Permissions)

## Which versions are affected by CVE-2021-43816?

3 open source packages ship an affected version, including github.com/containerd/containerd. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containerd/containerd` | Go | From 1.5.0 | 1.5.9 |
| `github.com/containerd/containerd` | Go | From 1.5.0 | 1.5.9 |
| `github.com/containerd/containerd` | Go | From 1.5.0 | 1.5.9 |

Products: Fedoraproject Fedora, Linuxfoundation Containerd.

## How do I fix CVE-2021-43816?

Upgrade github.com/containerd/containerd to 1.5.9 or later.

## Is CVE-2021-43816 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-43816 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43816 and fix it if it is affected.

What it is: CVE-2021-43816 is a high-severity vulnerability in Fedoraproject Fedora, published on 5 Jan 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-43816 exists.

Affected packages and fixed versions:
- github.com/containerd/containerd (Go): affected from 1.5.0; fixed in 1.5.9
- github.com/containerd/containerd (Go): affected from 1.5.0; fixed in 1.5.9
- github.com/containerd/containerd (Go): affected from 1.5.0; fixed in 1.5.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43816/ (Markdown: https://insights.sbomify.com/CVE-2021-43816/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43816
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43816
- OSV: https://osv.dev/vulnerability/CVE-2021-43816

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43816/
Summaries are generated and may contain mistakes; the official description above is the record.
