# CVE-2021-43822: SQL injection in jackalope/jackalope-doctrine-dbal

> Attackers can execute arbitrary SQL commands via crafted node names or queries in Jackalope Doctrine-DBAL, potentially compromising database integrity.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-ph98-v78f-jqrm

## What is CVE-2021-43822?

CVE-2021-43822 is a high-severity SQL injection vulnerability in jackalope-doctrine-dbal, published on 13 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jackalope Doctrine-DBAL is an implementation of the PHP Content Repository API (PHPCR) using a relational database to persist data. In affected versions users can provoke SQL injections if they can specify a node name or query. Upgrade to version 1.7.4 to resolve this issue. If that is not possible, you can escape all places where `$property` is used to filter `sv:name` in the class `Jackalope\Transport\DoctrineDBAL\Query\QOMWalker`: `XPath::escape($property)`. Node names and xpaths can contain `"` or `;` according to the JCR specification. The jackalope component that translates the query object model into doctrine dbal queries does not properly escape the names and paths, so that a accordingly crafted node name can lead to an SQL injection. If queries are never done from user input, or if you validate the user input to not contain `;`, you are not affected.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2021-43822?

2 open source packages ship an affected version, including jackalope/jackalope-doctrine-dbal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jackalope/jackalope-doctrine-dbal` | Packagist | All versions | 1.7.4 |
| `jackalope/jackalope-doctrine-dbal` | Packagist | All versions | 1.7.4 |

Products: Jackalope Doctrine-Dbal Project Jackalope Doctrine-Dbal.

## How do I fix CVE-2021-43822?

Upgrade jackalope/jackalope-doctrine-dbal to 1.7.4 or later.

## Is CVE-2021-43822 being exploited?

There is no known exploitation of CVE-2021-43822 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43822 and fix it if it is affected.

What it is: CVE-2021-43822 is a high-severity SQL injection vulnerability in jackalope-doctrine-dbal, published on 13 Dec 2021. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43822 in the wild and no public exploit code.

Affected packages and fixed versions:
- jackalope/jackalope-doctrine-dbal (Packagist): affected all versions; fixed in 1.7.4
- jackalope/jackalope-doctrine-dbal (Packagist): affected all versions; fixed in 1.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43822/ (Markdown: https://insights.sbomify.com/CVE-2021-43822/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43822
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43822
- OSV: https://osv.dev/vulnerability/CVE-2021-43822

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43822/
Summaries are generated and may contain mistakes; the official description above is the record.
