# CVE-2021-43838: Regular Expression Denial of Service (ReDoS) in jsx-slack

> An attacker can cause excessive resource consumption via ReDoS by injecting many JSX elements into blockquote tags in the jsx-slack library.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-55xv-f85c-248q

## What is CVE-2021-43838?

CVE-2021-43838 is a medium-severity denial of service vulnerability in yhatt jsx-slack, published on 17 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

jsx-slack is a library for building JSON objects for Slack Block Kit surfaces from JSX. In versions prior to 4.5.1 users are vulnerable to a regular expression denial-of-service (ReDoS) attack. If attacker can put a lot of JSX elements into `<blockquote>` tag, an internal regular expression for escaping characters may consume an excessive amount of computing resources. jsx-slack v4.5.1 has patched to a regex for escaping blockquote characters. Users are advised to upgrade as soon as possible.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-43838?

2 open source packages ship an affected version, including jsx-slack. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jsx-slack` | npm | All versions | 4.5.1 |
| `jsx-slack` | npm | All versions | 4.5.1 |

Products: Jsx-Slack Project Jsx-Slack.

## How do I fix CVE-2021-43838?

Upgrade jsx-slack to 4.5.1 or later.

## Is CVE-2021-43838 being exploited?

There is no known exploitation of CVE-2021-43838 in the wild and no public exploit code.

## Other vulnerabilities in yhatt jsx-slack

- [CVE-2021-43843](https://insights.sbomify.com/CVE-2021-43843/): Insufficient patch for Regular Expression Denial of Service (ReDoS) to jsx-slack v4.5.1 (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43838 and fix it if it is affected.

What it is: CVE-2021-43838 is a medium-severity denial of service vulnerability in yhatt jsx-slack, published on 17 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43838 in the wild and no public exploit code.

Affected packages and fixed versions:
- jsx-slack (npm): affected all versions; fixed in 4.5.1
- jsx-slack (npm): affected all versions; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43838/ (Markdown: https://insights.sbomify.com/CVE-2021-43838/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43838
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43838
- OSV: https://osv.dev/vulnerability/CVE-2021-43838

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43838/
Summaries are generated and may contain mistakes; the official description above is the record.
