# CVE-2021-43840: Path traversal in message_bus

> Attackers can read secret files via path traversal if diagnostics are enabled, requiring upgrade or disabling diagnostics.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-xmgj-5fh3-xjmm

## What is CVE-2021-43840?

CVE-2021-43840 is a medium-severity path traversal vulnerability in discourse message_bus, published on 17 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

message_bus is a messaging bus for Ruby processes and web clients. In versions prior to 3.3.7 users who deployed message bus with diagnostics features enabled (default off) are vulnerable to a path traversal bug, which could lead to disclosure of secret information on a machine if an unintended user were to gain access to the diagnostic route. The impact is also greater if there is no proxy for your web application as the number of steps up the directories is not bounded. For deployments which uses a proxy, the impact varies. For example, If a request goes through a proxy like Nginx with `merge_slashes` enabled, the number of steps up the directories that can be read is limited to 3 levels. This issue has been patched in version 3.3.7. Users unable to upgrade should ensure that MessageBus::Diagnostics is disabled.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-43840?

2 open source packages ship an affected version, including message_bus. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `message_bus` | RubyGems | All versions | 3.3.7 |
| `message_bus` | RubyGems | All versions | 3.3.7 |

Products: Discourse Message Bus.

## How do I fix CVE-2021-43840?

Upgrade message_bus to 3.3.7 or later.

## Is CVE-2021-43840 being exploited?

There is no known exploitation of CVE-2021-43840 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43840 and fix it if it is affected.

What it is: CVE-2021-43840 is a medium-severity path traversal vulnerability in discourse message_bus, published on 17 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43840 in the wild and no public exploit code.

Affected packages and fixed versions:
- message_bus (RubyGems): affected all versions; fixed in 3.3.7
- message_bus (RubyGems): affected all versions; fixed in 3.3.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43840/ (Markdown: https://insights.sbomify.com/CVE-2021-43840/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43840
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43840
- OSV: https://osv.dev/vulnerability/CVE-2021-43840

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43840/
Summaries are generated and may contain mistakes; the official description above is the record.
