# CVE-2021-43841: XSS by SVG upload in xwiki-platform

> Attackers can execute scripts via uploaded SVG files in XWiki, potentially leading to code execution or account takeover.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-9jq9-c2cv-pcrj

## What is CVE-2021-43841?

CVE-2021-43841 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 4 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

XWiki is a generic wiki platform offering runtime services for applications built on top of it. When using default XWiki configuration, it's possible for an attacker to upload an SVG containing a script executed when executing the download action on the file. This problem has been patched so that the default configuration doesn't allow to display the SVG files in the browser. Users are advised to update or to disallow uploads of SVG files.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-43841?

8 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore and org.xwiki.platform:xwiki-platform-tool-configuration-resources. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 12.10.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | All versions | 12.10.6 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 13.0 | 13.3RC1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 13.0 | 13.3RC1 |
| `org.xwiki.platform:xwiki-platform-tool-configuration-resources` | Maven | All versions | 12.10.6 |
| `org.xwiki.platform:xwiki-platform-tool-configuration-resources` | Maven | All versions | 12.10.6 |
| `org.xwiki.platform:xwiki-platform-tool-configuration-resources` | Maven | From 13.0 | 13.3RC1 |
| `org.xwiki.platform:xwiki-platform-tool-configuration-resources` | Maven | From 13.0 | 13.3RC1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2021-43841?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 12.10.6 or 13.3RC1.

## Is CVE-2021-43841 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-43841 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43841 and fix it if it is affected.

What it is: CVE-2021-43841 is a medium-severity cross-site scripting vulnerability in Xwiki Xwiki, published on 4 Feb 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-43841 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 12.10.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected all versions; fixed in 12.10.6
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 13.0; fixed in 13.3RC1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 13.0; fixed in 13.3RC1
- org.xwiki.platform:xwiki-platform-tool-configuration-resources (Maven): affected all versions; fixed in 12.10.6
- org.xwiki.platform:xwiki-platform-tool-configuration-resources (Maven): affected all versions; fixed in 12.10.6
- org.xwiki.platform:xwiki-platform-tool-configuration-resources (Maven): affected from 13.0; fixed in 13.3RC1
- org.xwiki.platform:xwiki-platform-tool-configuration-resources (Maven): affected from 13.0; fixed in 13.3RC1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43841/ (Markdown: https://insights.sbomify.com/CVE-2021-43841/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43841
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43841
- OSV: https://osv.dev/vulnerability/CVE-2021-43841

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43841/
Summaries are generated and may contain mistakes; the official description above is the record.
