CVE-2021-43850 Denial of Service in discourse

Medium 6.8 Published Updated

Admin users can trigger a Denial of Service attack via the message-bus diagnostics path, particularly affecting multisite Discourse instances.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2021-43850?

CVE-2021-43850 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 4 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Discourse is an open source platform for community discussion. In affected versions admins users can trigger a Denial of Service attack via the `/message-bus/_diagnostics` path. The impact of this vulnerability is greater on multisite Discourse instances (where multiple forums are served from a single application server) where any admin user on any of the forums are able to visit the `/message-bus/_diagnostics` path. The problem has been patched. Please upgrade to 2.8.0.beta10 or 2.7.12. No workarounds for this issue exist.

Weakness: CWE-20

Which versions are affected by CVE-2021-43850?

1 open source package ship an affected version, including discourse. It affects 1 product.

PackageAffectedFixed in
discourse BitnamiAll versions2.7.12

Products include Discourse Discourse.

How do I fix CVE-2021-43850?

Upgrade discourse to 2.7.12 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-43850 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-43850 exists.

All Discourse Discourse vulnerabilities

Sources

Also known as BIT-discourse-2021-43850, GHSA-59jr-pj65-qmvr.

Is CVE-2021-43850 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free