# CVE-2021-43850: Denial of Service in discourse

> Admin users can trigger a Denial of Service attack via the message-bus diagnostics path, particularly affecting multisite Discourse instances.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Jan 2022
- **Updated:** 22 Apr 2025
- **Also known as:** BIT-discourse-2021-43850, GHSA-59jr-pj65-qmvr

## What is CVE-2021-43850?

CVE-2021-43850 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 4 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Discourse is an open source platform for community discussion. In affected versions admins users can trigger a Denial of Service attack via the `/message-bus/_diagnostics` path. The impact of this vulnerability is greater on multisite Discourse instances (where multiple forums are served from a single application server) where any admin user on any of the forums are able to visit the `/message-bus/_diagnostics` path. The problem has been patched. Please upgrade to 2.8.0.beta10 or 2.7.12. No workarounds for this issue exist.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-43850?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2.7.12 |

Products: Discourse Discourse.

## How do I fix CVE-2021-43850?

Upgrade discourse to 2.7.12 or later.

## Is CVE-2021-43850 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-43850 exists.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43850 and fix it if it is affected.

What it is: CVE-2021-43850 is a medium-severity denial of service vulnerability in Discourse Discourse, published on 4 Jan 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-43850 exists.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2.7.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43850/ (Markdown: https://insights.sbomify.com/CVE-2021-43850/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43850
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43850
- OSV: https://osv.dev/vulnerability/CVE-2021-43850

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43850/
Summaries are generated and may contain mistakes; the official description above is the record.
