# CVE-2021-43853: Cross-Site Scripting in AjaxNetProfessional

> Attackers can execute arbitrary JavaScript via malicious JSON input in Ajax.NET Professional, potentially compromising user sessions.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-5q7q-qqw2-hjq7

## What is CVE-2021-43853?

CVE-2021-43853 is a high-severity cross-site scripting vulnerability in michaelschwarz Ajax.NET-Professional, published on 22 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Ajax.NET Professional (AjaxPro) is an AJAX framework available for Microsoft ASP.NET. Affected versions of this package are vulnerable to JavaScript object injection which may result in cross site scripting when leveraged by a malicious user. The affected core relates to JavaScript object creation when parsing json input. Releases before version 21.12.22.1 are affected. A workaround exists that replaces one of the core JavaScript files embedded in the library. See the GHSA-5q7q-qqw2-hjq7 for workaround details.

Weakness: CWE-502 (Deserialization of Untrusted Data), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2021-43853?

2 open source packages ship an affected version, including AjaxNetProfessional. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `AjaxNetProfessional` | NuGet | All versions | 21.12.22.1 |
| `AjaxNetProfessional` | NuGet | All versions | 21.12.22.1 |

Products: Ajax.net Professional Project Ajax.net Professional.

## How do I fix CVE-2021-43853?

Upgrade AjaxNetProfessional to 21.12.22.1 or later.

## Is CVE-2021-43853 being exploited?

There is no known exploitation of CVE-2021-43853 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43853 and fix it if it is affected.

What it is: CVE-2021-43853 is a high-severity cross-site scripting vulnerability in michaelschwarz Ajax.NET-Professional, published on 22 Dec 2021. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-43853 in the wild and no public exploit code.

Affected packages and fixed versions:
- AjaxNetProfessional (NuGet): affected all versions; fixed in 21.12.22.1
- AjaxNetProfessional (NuGet): affected all versions; fixed in 21.12.22.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43853/ (Markdown: https://insights.sbomify.com/CVE-2021-43853/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43853
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43853
- OSV: https://osv.dev/vulnerability/CVE-2021-43853

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43853/
Summaries are generated and may contain mistakes; the official description above is the record.
