# CVE-2021-43854: Inefficient Regular Expression Complexity in nltk

> Attackers can cause denial of service in NLTK applications by submitting crafted long inputs to tokenization functions, leading to excessive CPU consumption.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-43854, GHSA-f8m6-h2c7-8h9x, PYSEC-2021-859, UBUNTU-CVE-2021-43854

## What is CVE-2021-43854?

CVE-2021-43854 is a high-severity denial of service vulnerability in nltk, published on 23 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NLTK (Natural Language Toolkit) is a suite of open source Python modules, data sets, and tutorials supporting research and development in Natural Language Processing. Versions prior to 3.6.5 are vulnerable to regular expression denial of service (ReDoS) attacks. The vulnerability is present in PunktSentenceTokenizer, sent_tokenize and word_tokenize. Any users of this class, or these two functions, are vulnerable to the ReDoS attack. In short, a specifically crafted long input to any of these vulnerable functions will cause them to take a significant amount of execution time. If your program relies on any of the vulnerable functions for tokenizing unpredictable user input, then we would strongly recommend upgrading to a version of NLTK without the vulnerability. For users unable to upgrade the execution time can be bounded by limiting the maximum length of an input to any of the vulnerable functions. Our recommendation is to implement such a limit.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-43854?

3 open source packages ship an affected version, including nltk. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nltk` | PyPI | All versions | 3.6.5 |
| `nltk` | PyPI | All versions | 3.6.6 |
| `nltk` | PyPI | All versions | 3.6.6 |

Products: Nltk Nltk.

## How do I fix CVE-2021-43854?

Upgrade nltk to a fixed version for your release line: 3.6.5 or 3.6.6.

## Is CVE-2021-43854 being exploited?

There is no known exploitation of CVE-2021-43854 in the wild and no public exploit code.

## Other vulnerabilities in nltk

- [CVE-2026-0848](https://insights.sbomify.com/CVE-2026-0848/): Arbitrary Code Execution in NLTK StanfordSegmenter via Untrusted JAR Loading (critical 10.0)
- [CVE-2025-14009](https://insights.sbomify.com/CVE-2025-14009/): Zip Slip Vulnerability in nltk/nltk Leading to Remote Code Execution (critical 10.0)
- [CVE-2026-78683](https://insights.sbomify.com/CVE-2026-78683/): NLTK before 3.10.0 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.4)
- [CVE-2026-79657](https://insights.sbomify.com/CVE-2026-79657/): NLTK before 3.10.3 Remote Code Execution via Unsafe Pickle Deserialization (critical 9.3)
- [CVE-2026-79675](https://insights.sbomify.com/CVE-2026-79675/): NLTK before 3.10.3 JVM Argument Injection via Per-Call Options (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43854 and fix it if it is affected.

What it is: CVE-2021-43854 is a high-severity denial of service vulnerability in nltk, published on 23 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43854 in the wild and no public exploit code.

Affected packages and fixed versions:
- nltk (PyPI): affected all versions; fixed in 3.6.5
- nltk (PyPI): affected all versions; fixed in 3.6.6
- nltk (PyPI): affected all versions; fixed in 3.6.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43854/ (Markdown: https://insights.sbomify.com/CVE-2021-43854/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43854
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43854
- OSV: https://osv.dev/vulnerability/CVE-2021-43854

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43854/
Summaries are generated and may contain mistakes; the official description above is the record.
