# CVE-2021-43857: Gerapy may contain remote code execution vulnerability

> Attackers can execute arbitrary code on servers running the Gerapy distributed crawler management framework.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** CVE-2021-44597, GHSA-9w7f-m4j4-j3xw, PYSEC-2021-867

## What is CVE-2021-43857?

CVE-2021-43857 is a critical command injection vulnerability in Gerapy, published on 27 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Gerapy is a distributed crawler management framework. Gerapy prior to version 0.9.8 is vulnerable to remote code execution, and this issue is patched in version 0.9.8.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2021-43857?

3 open source packages ship an affected version, including gerapy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gerapy` | PyPI | All versions | 0.9.8 |
| `gerapy` | PyPI | All versions | 0.9.8 |
| `gerapy` | PyPI | All versions | 0.9.8 |

Products: Gerapy Gerapy.

## How do I fix CVE-2021-43857?

Upgrade gerapy to 0.9.8 or later.

## Is CVE-2021-43857 being exploited?

There is no known exploitation of CVE-2021-43857 in the wild and no public exploit code.

Public exploit code:

- Gerapy prior to version 0.9.8 is vulnerable to remote code execution. This issue is patched in version 0.9.8. (github_poc): https://github.com/LongWayHomie/CVE-2021-43857
- Proof of Concept exploit for CVE‑2021‑43857: Authenticated Remote Code Execution in Gerapy (<0.9.8). Updated and automated version of the original Exploit‑DB PoC for educational and authorized testing purposes only. (github_poc): https://github.com/ProwlSec/gerapy-cve-2021-43857
- CVE-2021-43857(gerapy命令执行) (github_poc): https://github.com/lowkey0808/CVE-2021-43857
- Gerapy 0.9.7 - Remote Code Execution (RCE) (Authenticated) (exploitdb)
- Optimized exploit for CVE-2021-43857 affecting Gerapy < 0.9.8 (github_poc): https://github.com/G4sp4rCS/CVE-2021-43857-POC
- https://github.com/afifudinmtop/CVE-2021-43857-Gerapy-v0.9.7 (github_poc): https://github.com/afifudinmtop/CVE-2021-43857-Gerapy-v0.9.7

## Other vulnerabilities in Gerapy

- [CVE-2021-32849](https://insights.sbomify.com/CVE-2021-32849/): Arbitrary command execution in Gerapy (high 8.8)
- [CVE-2020-7698](https://insights.sbomify.com/CVE-2020-7698/): Command Injection (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43857 and fix it if it is affected.

What it is: CVE-2021-43857 is a critical command injection vulnerability in Gerapy, published on 27 Dec 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43857 in the wild and no public exploit code.

Affected packages and fixed versions:
- gerapy (PyPI): affected all versions; fixed in 0.9.8
- gerapy (PyPI): affected all versions; fixed in 0.9.8
- gerapy (PyPI): affected all versions; fixed in 0.9.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43857/ (Markdown: https://insights.sbomify.com/CVE-2021-43857/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43857
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43857
- OSV: https://osv.dev/vulnerability/CVE-2021-43857

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43857/
Summaries are generated and may contain mistakes; the official description above is the record.
