# CVE-2021-43859: Denial of Service by injecting highly recursive collections or maps in XStream

> Remote attackers can cause denial of service by sending highly recursive data to XStream, consuming all CPU resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2022
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-jenkins-2021-43859, DEBIAN-CVE-2021-43859, DLA-2924-1, GHSA-rmr5-cpv2-vgjf, OESA-2022-1512, OESA-2022-2066, SUSE-SU-2022:0817-1, UBUNTU-CVE-2021-43859, openSUSE-SU-2022:0817-1, openSUSE-SU-2024:11809-1

## What is CVE-2021-43859?

CVE-2021-43859 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

XStream is an open source java library to serialize objects to XML and back again. Versions prior to 1.4.19 may allow a remote attacker to allocate 100% CPU time on the target system depending on CPU type or parallel execution of such a payload resulting in a denial of service only by manipulating the processed input stream. XStream 1.4.19 monitors and accumulates the time it takes to add elements to collections and throws an exception if a set threshold is exceeded. Users are advised to upgrade as soon as possible. Users unable to upgrade may set the NO_REFERENCE mode to prevent recursion. See GHSA-rmr5-cpv2-vgjf for further details on a workaround if an upgrade is not possible.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2021-43859?

3 open source packages ship an affected version, including com.thoughtworks.xstream:xstream and jenkins. It affects 11 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.19 |
| `com.thoughtworks.xstream:xstream` | Maven | All versions | 1.4.19 |
| `jenkins` | Bitnami | All versions | 2.319.3, 2.334.0 |
| `xstream` | SUSE:Linux Enterprise Module for Development Tools 15 SP3 | All versions | 1.4.19-3.18.2 |
| `xstream` | SUSE:Linux Enterprise Real Time 15 SP2 | All versions | 1.4.19-3.18.2 |
| `xstream` | SUSE:Manager Server Module 4.1 | All versions | 1.4.19-3.18.2 |
| `xstream` | SUSE:Manager Server Module 4.2 | All versions | 1.4.19-3.18.2 |
| `xstream` | openSUSE:Leap 15.3 | All versions | 1.4.19-3.18.2 |
| `xstream` | openSUSE:Tumbleweed | All versions | 1.4.19-1.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Jenkins Jenkins, Oracle Commerce Guided Search, Oracle Communications Brm - Elastic Charging Engine, Oracle Communications Cloud Native Core Automated Test Suite, Oracle Communications Diameter Intelligence Hub, Oracle Communications Policy Management, Oracle Flexcube Private Banking, Oracle Retail Xstore Point of Service, Xstream Xstream.

## How do I fix CVE-2021-43859?

Upgrade com.thoughtworks.xstream:xstream to 1.4.19 or later.

## Is CVE-2021-43859 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-43859 exists.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43859 and fix it if it is affected.

What it is: CVE-2021-43859 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 1 Feb 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-43859 exists.

Affected packages and fixed versions:
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.19
- com.thoughtworks.xstream:xstream (Maven): affected all versions; fixed in 1.4.19
- jenkins (Bitnami): affected all versions; fixed in 2.319.3, 2.334.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43859/ (Markdown: https://insights.sbomify.com/CVE-2021-43859/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43859
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43859
- OSV: https://osv.dev/vulnerability/CVE-2021-43859

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43859/
Summaries are generated and may contain mistakes; the official description above is the record.
