{"answers":{"affected":"2 open source packages ship an affected version, including mermaid. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-43861 in the wild and no public exploit code.","fix":"Upgrade mermaid to 8.13.8 or later.","what":"CVE-2021-43861 is a high-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 30 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-43861 and fix it if it is affected.\n\nWhat it is: CVE-2021-43861 is a high-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 30 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-43861 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mermaid (npm): affected all versions; fixed in 8.13.8\n- mermaid (npm): affected all versions; fixed in 8.13.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43861/ (Markdown: https://insights.sbomify.com/CVE-2021-43861/index.md)","id":"CVE-2021-43861","markdown":"https://insights.sbomify.com/CVE-2021-43861/index.md","name":"CVE-2021-43861","record":{"aliases":["DEBIAN-CVE-2021-43861","GHSA-p3rp-vmj9-gv6v","UBUNTU-CVE-2021-43861"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript diagramming library","requires_auth":"high_privilege","summary":"Attackers can execute arbitrary JavaScript on victims' machines via malicious diagrams in the Mermaid library.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mermaid","vendor":"mermaid_project"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Mermaid is a Javascript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. Prior to version 8.13.8, malicious diagrams can run javascript code at diagram readers' machines. Users should upgrade to version 8.13.8 to receive a patch. There are no known workarounds aside from upgrading.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Incorrect sanitisation function leads to `XSS`","id":"CVE-2021-43861","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2021"},"n_packages":2,"n_references":3,"next":{"headline":"Self XSS on user input","id":"CVE-2021-43862"},"packages":[{"ecosystem":"npm","fixed":["8.13.8"],"introduced":["0"],"last_affected":[],"package":"mermaid","purl":null,"source":"GHSA-p3rp-vmj9-gv6v"},{"ecosystem":"npm","fixed":["8.13.8"],"introduced":["0"],"last_affected":[],"package":"mermaid","purl":"pkg:npm/mermaid","source":"GHSA-p3rp-vmj9-gv6v"}],"prev":{"headline":"Permissions granted to applications can be hidden from the user at install time","id":"CVE-2021-43860"},"products":["mermaid"],"published":"2021-12-30","related":[{"cvss_score":6.1,"headline":"Cross-site Scripting in Mermaid","id":"CVE-2021-35513","kev_date_added":null,"published":"2021-06-27"},{"cvss_score":5.3,"headline":"Mermaid Gantt Charts are vulnerable to an Infinite Loop DoS","id":"CVE-2026-41150","kev_date_added":null,"published":"2026-05-29"},{"cvss_score":5.3,"headline":"Mermaid: Improper sanitization of configuration leads to CSS injection","id":"CVE-2026-41159","kev_date_added":null,"published":"2026-05-29"},{"cvss_score":5.1,"headline":"Mermaid does not properly sanitize architecture diagram iconText leading to XSS","id":"CVE-2025-54880","kev_date_added":null,"published":"2025-08-19"},{"cvss_score":4.1,"headline":"Arbitrary `CSS` injection into the generated graph affecting the container HTML in mermaid.js","id":"CVE-2022-31108","kev_date_added":null,"published":"2022-06-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["mermaid-js"]},"summary":"Attackers can execute arbitrary JavaScript on victims' machines via malicious diagrams in the Mermaid library.","url":"https://insights.sbomify.com/CVE-2021-43861/"}