# CVE-2021-43861: Incorrect sanitisation function leads to `XSS`

> Attackers can execute arbitrary JavaScript on victims' machines via malicious diagrams in the Mermaid library.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Dec 2021
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2021-43861, GHSA-p3rp-vmj9-gv6v, UBUNTU-CVE-2021-43861

## What is CVE-2021-43861?

CVE-2021-43861 is a high-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 30 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Mermaid is a Javascript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. Prior to version 8.13.8, malicious diagrams can run javascript code at diagram readers' machines. Users should upgrade to version 8.13.8 to receive a patch. There are no known workarounds aside from upgrading.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2021-43861?

2 open source packages ship an affected version, including mermaid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mermaid` | npm | All versions | 8.13.8 |
| `mermaid` | npm | All versions | 8.13.8 |

Products: Mermaid Project Mermaid.

## How do I fix CVE-2021-43861?

Upgrade mermaid to 8.13.8 or later.

## Is CVE-2021-43861 being exploited?

There is no known exploitation of CVE-2021-43861 in the wild and no public exploit code.

## Other vulnerabilities in mermaid-js mermaid

- [CVE-2021-35513](https://insights.sbomify.com/CVE-2021-35513/): Cross-site Scripting in Mermaid (medium 6.1)
- [CVE-2026-41150](https://insights.sbomify.com/CVE-2026-41150/): Mermaid Gantt Charts are vulnerable to an Infinite Loop DoS (medium 5.3)
- [CVE-2026-41159](https://insights.sbomify.com/CVE-2026-41159/): Mermaid: Improper sanitization of configuration leads to CSS injection (medium 5.3)
- [CVE-2025-54880](https://insights.sbomify.com/CVE-2025-54880/): Mermaid does not properly sanitize architecture diagram iconText leading to XSS (medium 5.1)
- [CVE-2022-31108](https://insights.sbomify.com/CVE-2022-31108/): Arbitrary `CSS` injection into the generated graph affecting the container HTML in mermaid.js (medium 4.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-43861 and fix it if it is affected.

What it is: CVE-2021-43861 is a high-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 30 Dec 2021. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-43861 in the wild and no public exploit code.

Affected packages and fixed versions:
- mermaid (npm): affected all versions; fixed in 8.13.8
- mermaid (npm): affected all versions; fixed in 8.13.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-43861/ (Markdown: https://insights.sbomify.com/CVE-2021-43861/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-43861
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-43861
- OSV: https://osv.dev/vulnerability/CVE-2021-43861

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-43861/
Summaries are generated and may contain mistakes; the official description above is the record.
