{"answers":{"affected":"2 open source packages ship an affected version, including guacamole and guacamole-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-43999 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-43999 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-43999 is a high-severity authentication bypass vulnerability in Apache Guacamole, published on 11 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-43999 and fix it if it is affected.\n\nWhat it is: CVE-2021-43999 is a high-severity authentication bypass vulnerability in Apache Guacamole, published on 11 Jan 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-43999 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- guacamole (Bitnami): affected from 1.2.0 up to 1.2.0; no fix listed\n- guacamole-server (Bitnami): affected from 1.2.0 up to 1.2.0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-43999/ (Markdown: https://insights.sbomify.com/CVE-2021-43999/index.md)","id":"CVE-2021-43999","markdown":"https://insights.sbomify.com/CVE-2021-43999/index.md","name":"CVE-2021-43999","record":{"aliases":["BIT-guacamole-2021-43999","BIT-guacamole-server-2021-43999","GHSA-v83c-8hcj-4545","UBUNTU-CVE-2021-43999"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache Guacamole","requires_auth":"low_privilege","summary":"Attackers can assume other users' identities via improper SAML validation if SAML support is enabled in Apache Guacamole.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"guacamole","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Apache Guacamole 1.2.0 and 1.3.0 do not properly validate responses received from a SAML identity provider. If SAML support is enabled, this may allow a malicious user to assume the identity of another Guacamole user.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Improper validation of SAML responses","id":"CVE-2021-43999","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"auth_bypass","year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in JT2Go","id":"CVE-2021-44000"},"packages":[{"ecosystem":"Bitnami","fixed":[],"introduced":["1.2.0","1.3.0"],"last_affected":["1.2.0","1.3.0"],"package":"guacamole","purl":"pkg:bitnami/guacamole","source":"BIT-guacamole-2021-43999"},{"ecosystem":"Bitnami","fixed":[],"introduced":["1.2.0","1.3.0"],"last_affected":["1.2.0","1.3.0"],"package":"guacamole-server","purl":"pkg:bitnami/guacamole-server","source":"BIT-guacamole-server-2021-43999"}],"prev":{"headline":"HashiCorp Vault Incorrect Permission Assignment for Critical Resource","id":"CVE-2021-43998"},"products":["Apache Guacamole"],"published":"2022-01-11","related":[{"cvss_score":8.1,"headline":"Apache Guacamole Race Condition vulnerability","id":"CVE-2017-3158","kev_date_added":null,"published":"2018-01-18"},{"cvss_score":7.5,"headline":"Apache Guacamole: Integer overflow in handling of VNC image buffers","id":"CVE-2023-43826","kev_date_added":null,"published":"2023-12-19"},{"cvss_score":7.5,"headline":"Null dereference in n/a","id":"CVE-2019-19603","kev_date_added":null,"published":"2019-12-09"},{"cvss_score":7.5,"headline":"Missing Encryption of Sensitive Data in Apache Guacamole","id":"CVE-2018-1340","kev_date_added":null,"published":"2019-02-07"},{"cvss_score":6.8,"headline":"Apache Guacamole: Improper input validation of console codes","id":"CVE-2024-35164","kev_date_added":null,"published":"2025-07-02"},{"cvss_score":6.8,"headline":"Apache Guacamole: Use-after-free in handling of RDP audio input buffer","id":"CVE-2023-30576","kev_date_added":null,"published":"2023-06-07"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache Software Foundation"]},"summary":"Attackers can assume other users' identities via improper SAML validation if SAML support is enabled in Apache Guacamole.","url":"https://insights.sbomify.com/CVE-2021-43999/"}