CVE-2021-44025 Cross-site scripting in n/a
An attacker can execute arbitrary scripts in a victim's browser via a malicious attachment filename in Roundcube webmail.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2021-44025?
CVE-2021-44025 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 19 Nov 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Roundcube before 1.3.17 and 1.4.x before 1.4.12 is prone to XSS in handling an attachment's filename extension when displaying a MIME type warning message.
Weakness: CWE-79
Which versions are affected by CVE-2021-44025?
1 open source package ship an affected version, including roundcube. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
roundcube Bitnami | All versions | 1.3.17, 1.4.12 |
Products include Debian Debian Linux, Fedoraproject Fedora, Roundcube Webmail.
How do I fix CVE-2021-44025?
Upgrade roundcube to a fixed version for your release line: 1.3.17 or 1.4.12.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2021-44025 being exploited?
There is no known exploitation of CVE-2021-44025 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as BIT-roundcube-2021-44025, DEBIAN-CVE-2021-44025, GHSA-w383-2hxw-wjrr, UBUNTU-CVE-2021-44025.