{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-44038 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2021-44038 is a high-severity vulnerability in n/a, published on 19 Nov 2021. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-44038 and fix it if it is affected.\n\nWhat it is: CVE-2021-44038 is a high-severity vulnerability in n/a, published on 19 Nov 2021. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-44038 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-44038/ (Markdown: https://insights.sbomify.com/CVE-2021-44038/index.md)","id":"CVE-2021-44038","markdown":"https://insights.sbomify.com/CVE-2021-44038/index.md","name":"CVE-2021-44038","record":{"aliases":["AZL-36984","AZL-7336","CLSA-2022-1643112395","CLSA-2022-1643113123","CLSA-2024-1734007022","CLSA-2025-1762800667","GHSA-h99v-fr29-7p28","UBUNTU-CVE-2021-44038","openSUSE-SU-2024:12504-1"],"analysis":{"component_type":"operating_system","fix_type":"patch","impacts":["privilege_escalation"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Quagga routing software","requires_auth":"low_privilege","summary":"Local attackers can escalate privileges to root via unsafe file permissions in the Quagga package installation process.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"quagga","vendor":"quagga"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-59","name":"Improper Link Resolution Before File Access"}],"description":"An issue was discovered in Quagga through 1.2.4. Unsafe chown/chmod operations in the suggested spec file allow users (with control of the non-root-owned directory /etc/quagga) to escalate their privileges to root upon package installation or update.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Privilege escalation in n/a","id":"CVE-2021-44038","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"privilege_escalation","year":"2021"},"n_packages":1,"n_references":2,"next":{"headline":"HTTP request line fuzzing attacks","id":"CVE-2021-44040"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.2.4-5.1"],"introduced":["0"],"last_affected":[],"package":"quagga","purl":"pkg:rpm/opensuse/quagga\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:12504-1"}],"prev":{"headline":"Business logic in n/a","id":"CVE-2021-44037"},"products":["n/a"],"published":"2021-11-19","related":[{"cvss_score":8.2,"headline":"Denial of service in Protocol","id":"CVE-2017-3224","kev_date_added":null,"published":"2018-07-24"},{"cvss_score":7.5,"headline":"Denial of service in n/a","id":"CVE-2017-5495","kev_date_added":null,"published":"2017-01-24"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2011-3327","kev_date_added":null,"published":"2011-10-10"},{"cvss_score":6.5,"headline":"Memory corruption in n/a","id":"CVE-2010-2948","kev_date_added":null,"published":"2010-09-10"},{"cvss_score":6.3,"headline":"Denial of service in n/a","id":"CVE-2007-1995","kev_date_added":null,"published":"2007-04-12"},{"cvss_score":5,"headline":"Denial of service in n/a","id":"CVE-2012-0255","kev_date_added":null,"published":"2012-04-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Local attackers can escalate privileges to root via unsafe file permissions in the Quagga package installation process.","url":"https://insights.sbomify.com/CVE-2021-44038/"}