# CVE-2021-44111: Path Traversal in S-Cart

> Attackers can exploit a directory traversal flaw in the backup download feature to read arbitrary files from the server.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2022
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-h676-pjr4-hgqx

## What is CVE-2021-44111?

CVE-2021-44111 is a medium-severity path traversal vulnerability in n/a, published on 11 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A Directory Traversal vulnerability exists in S-Cart 6.7 via download in sc-admin/backup.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2021-44111?

2 open source packages ship an affected version, including s-cart/s-cart. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `s-cart/s-cart` | Packagist | All versions | 6.7.2 |
| `s-cart/s-cart` | Packagist | All versions | 6.7.2 |

Products: S-Cart S-Cart.

## How do I fix CVE-2021-44111?

Upgrade s-cart/s-cart to 6.7.2 or later.

## Is CVE-2021-44111 being exploited?

There is no known exploitation of CVE-2021-44111 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-38847](https://insights.sbomify.com/CVE-2021-38847/): File upload in n/a (high 8.8)
- [CVE-2020-28456](https://insights.sbomify.com/CVE-2020-28456/): Cross-site Scripting (XSS) (high 7.3)
- [CVE-2020-28457](https://insights.sbomify.com/CVE-2020-28457/): Cross-site Scripting (XSS) (high 7.2)
- [CVE-2022-21149](https://insights.sbomify.com/CVE-2022-21149/): Cross-site Scripting (XSS) (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44111 and fix it if it is affected.

What it is: CVE-2021-44111 is a medium-severity path traversal vulnerability in n/a, published on 11 Feb 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-44111 in the wild and no public exploit code.

Affected packages and fixed versions:
- s-cart/s-cart (Packagist): affected all versions; fixed in 6.7.2
- s-cart/s-cart (Packagist): affected all versions; fixed in 6.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44111/ (Markdown: https://insights.sbomify.com/CVE-2021-44111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44111
- OSV: https://osv.dev/vulnerability/CVE-2021-44111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44111/
Summaries are generated and may contain mistakes; the official description above is the record.
