# CVE-2021-44140: Arbitrary file deletion on logout

> Remote attackers can delete arbitrary files on the server via a crafted logout request in Apache JSPWiki.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-8gw6-w5rw-4g5c

## What is CVE-2021-44140?

CVE-2021-44140 is a critical path traversal vulnerability in Apache JSPWiki, published on 24 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Remote attackers may delete arbitrary files in a system hosting a JSPWiki instance, versions up to 2.11.0.M8, by using a carefuly crafted http request on logout, given that those files are reachable to the user running the JSPWiki instance. Apache JSPWiki users should upgrade to 2.11.0 or later.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2021-44140?

2 open source packages ship an affected version, including org.apache.jspwiki:jspwiki-main. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.jspwiki:jspwiki-main` | Maven | All versions | 2.11.0 |
| `org.apache.jspwiki:jspwiki-main` | Maven | All versions | 2.11.0 |

Products: Apache Jspwiki.

## How do I fix CVE-2021-44140?

Upgrade org.apache.jspwiki:jspwiki-main to 2.11.0 or later.

## Is CVE-2021-44140 being exploited?

There is no known exploitation of CVE-2021-44140 in the wild and no public exploit code.

## Other vulnerabilities in Apache JSPWiki

- [CVE-2026-28812](https://insights.sbomify.com/CVE-2026-28812/): Apache JSPWiki: UserManager does not sanity-check user database at startup (critical 9.8)
- [CVE-2026-28813](https://insights.sbomify.com/CVE-2026-28813/): Apache JSPWiki: JSPWiki vulnerable to JSON hijacking (high 8.8)
- [CVE-2022-34158](https://insights.sbomify.com/CVE-2022-34158/): User Group Privilege Escalation (high 8.8)
- [CVE-2022-24947](https://insights.sbomify.com/CVE-2022-24947/): Apache JSPWiki CSRF Account Takeover (high 8.8)
- [CVE-2026-28811](https://insights.sbomify.com/CVE-2026-28811/): Apache JSPWiki: Error Handling - Reveals Error Details (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44140 and fix it if it is affected.

What it is: CVE-2021-44140 is a critical path traversal vulnerability in Apache JSPWiki, published on 24 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-44140 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.jspwiki:jspwiki-main (Maven): affected all versions; fixed in 2.11.0
- org.apache.jspwiki:jspwiki-main (Maven): affected all versions; fixed in 2.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44140/ (Markdown: https://insights.sbomify.com/CVE-2021-44140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44140
- OSV: https://osv.dev/vulnerability/CVE-2021-44140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44140/
Summaries are generated and may contain mistakes; the official description above is the record.
