# CVE-2021-44144: Asterix Heap-based Buffer Overflow

> A heap-based buffer over-read in Croatia Control Asterix allows potential memory disclosure or crashes, requiring vendor attention.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6mmf-v5q7-vw2w, PYSEC-2021-860

## What is CVE-2021-44144?

CVE-2021-44144 is a critical memory corruption vulnerability in n/a, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Croatia Control Asterix 2.8.1 has a heap-based buffer over-read, with additional details to be disclosed at a later date.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2021-44144?

3 open source packages ship an affected version, including asterix-decoder and asterix_decoder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `asterix-decoder` | PyPI | All versions | 0.7.2 |
| `asterix-decoder` | PyPI | All versions | 0.7.2 |
| `asterix_decoder` | PyPI | All versions | 0.7.2 |

Products: Crocontrol Asterix.

## How do I fix CVE-2021-44144?

Upgrade asterix-decoder to 0.7.2 or later.

## Is CVE-2021-44144 being exploited?

There is no known exploitation of CVE-2021-44144 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44144 and fix it if it is affected.

What it is: CVE-2021-44144 is a critical memory corruption vulnerability in n/a, published on 22 Nov 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-44144 in the wild and no public exploit code.

Affected packages and fixed versions:
- asterix-decoder (PyPI): affected all versions; fixed in 0.7.2
- asterix-decoder (PyPI): affected all versions; fixed in 0.7.2
- asterix_decoder (PyPI): affected all versions; fixed in 0.7.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44144/ (Markdown: https://insights.sbomify.com/CVE-2021-44144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44144
- OSV: https://osv.dev/vulnerability/CVE-2021-44144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44144/
Summaries are generated and may contain mistakes; the official description above is the record.
