{"answers":{"affected":"2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-44223 in the wild and no public exploit code.","fix":"Upgrade wordpress to 5.8.0 or later.","what":"CVE-2021-44223 is a high-severity vulnerability in Wordpress Wordpress, published on 25 Nov 2021."},"fix_prompt":"Check this codebase for CVE-2021-44223 and fix it if it is affected.\n\nWhat it is: CVE-2021-44223 is a high-severity vulnerability in Wordpress Wordpress, published on 25 Nov 2021. \nExploitation: There is no known exploitation of CVE-2021-44223 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wordpress (Bitnami): affected all versions; fixed in 5.8.0\n- wordpress-multisite (Bitnami): affected all versions; fixed in 5.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-44223/ (Markdown: https://insights.sbomify.com/CVE-2021-44223/index.md)","id":"CVE-2021-44223","markdown":"https://insights.sbomify.com/CVE-2021-44223/index.md","name":"CVE-2021-44223","record":{"aliases":["BIT-wordpress-2021-44223","BIT-wordpress-multisite-2021-44223","DEBIAN-CVE-2021-44223","GHSA-m8cv-g4gv-cx2g","UBUNTU-CVE-2021-44223"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"wordpress","vendor":"wordpress"}],"cvss":{"score":8.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AC:H/AV:N/A:H/C:H/I:H/PR:N/S:U/UI:N","version":"3.1"},"cwes":[],"description":"WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"WordPress before 5.8 lacks support for the Update URI plugin header.","id":"CVE-2021-44223","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"wordpress:wordpress","products":["wordpress:wordpress"],"type":null,"year":"2021"},"n_packages":2,"n_references":2,"next":{"headline":"Possible NULL dereference or SSRF in forward proxy configurations in Apache HTTP Server 2.4.51 and earlier","id":"CVE-2021-44224"},"packages":[{"ecosystem":"Bitnami","fixed":["5.8.0"],"introduced":["0"],"last_affected":[],"package":"wordpress","purl":"pkg:bitnami/wordpress","source":"BIT-wordpress-2021-44223"},{"ecosystem":"Bitnami","fixed":["5.8.0"],"introduced":["0"],"last_affected":[],"package":"wordpress-multisite","purl":"pkg:bitnami/wordpress-multisite","source":"BIT-wordpress-multisite-2021-44223"}],"prev":{"headline":"Missing authorization in SIMATIC eaSie Core Package","id":"CVE-2021-44222"},"products":["n/a"],"published":"2021-11-25","related":[{"cvss_score":9.8,"headline":"WordPress Core Interpretation Conflict","id":"CVE-2026-63030","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":8.1,"headline":"WordPress Core Remote File Inclusion","id":"CVE-2026-87902","kev_date_added":"2026-09-25","published":"2026-09-22"},{"cvss_score":5.9,"headline":"WordPress Core SQL Injection","id":"CVE-2026-60137","kev_date_added":"2026-07-21","published":"2026-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2012-2399","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2012-2400","kev_date_added":null,"published":"2012-04-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3122","kev_date_added":null,"published":"2011-08-10"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2011-3125","kev_date_added":null,"published":"2011-08-10"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2021-44223/"}