# CVE-2021-44223: WordPress before 5.8 lacks support for the Update URI plugin header.


- **Severity:** High 8.1 (`CVSS:3.1/AC:H/AV:N/A:H/C:H/I:H/PR:N/S:U/UI:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Nov 2021
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-wordpress-2021-44223, BIT-wordpress-multisite-2021-44223, DEBIAN-CVE-2021-44223, GHSA-m8cv-g4gv-cx2g, UBUNTU-CVE-2021-44223

## What is CVE-2021-44223?

CVE-2021-44223 is a high-severity vulnerability in Wordpress Wordpress, published on 25 Nov 2021. 

### Official description

WordPress before 5.8 lacks support for the Update URI plugin header. This makes it easier for remote attackers to execute arbitrary code via a supply-chain attack against WordPress installations that use any plugin for which the slug satisfies the naming constraints of the WordPress.org Plugin Directory but is not yet present in that directory.

## Which versions are affected by CVE-2021-44223?

2 open source packages ship an affected version, including wordpress and wordpress-multisite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wordpress` | Bitnami | All versions | 5.8.0 |
| `wordpress-multisite` | Bitnami | All versions | 5.8.0 |

Products: Wordpress Wordpress.

## How do I fix CVE-2021-44223?

Upgrade wordpress to 5.8.0 or later.

## Is CVE-2021-44223 being exploited?

There is no known exploitation of CVE-2021-44223 in the wild and no public exploit code.

## Other vulnerabilities in Wordpress Wordpress

- [CVE-2026-63030](https://insights.sbomify.com/CVE-2026-63030/): WordPress Core Interpretation Conflict (critical 9.8, exploited in the wild)
- [CVE-2026-87902](https://insights.sbomify.com/CVE-2026-87902/): WordPress Core Remote File Inclusion (high 8.1, exploited in the wild)
- [CVE-2026-60137](https://insights.sbomify.com/CVE-2026-60137/): WordPress Core SQL Injection (medium 5.9, exploited in the wild)
- [CVE-2012-2399](https://insights.sbomify.com/CVE-2012-2399/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2012-2400](https://insights.sbomify.com/CVE-2012-2400/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-44223 and fix it if it is affected.

What it is: CVE-2021-44223 is a high-severity vulnerability in Wordpress Wordpress, published on 25 Nov 2021. 
Exploitation: There is no known exploitation of CVE-2021-44223 in the wild and no public exploit code.

Affected packages and fixed versions:
- wordpress (Bitnami): affected all versions; fixed in 5.8.0
- wordpress-multisite (Bitnami): affected all versions; fixed in 5.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-44223/ (Markdown: https://insights.sbomify.com/CVE-2021-44223/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-44223
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-44223
- OSV: https://osv.dev/vulnerability/CVE-2021-44223

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-44223/
Summaries are generated and may contain mistakes; the official description above is the record.
