{"answers":{"affected":"1 open source package ship an affected version, including apache. It affects 12 products.","exploited":"There is no known exploitation of CVE-2021-44224 in the wild and no public exploit code.","fix":"Upgrade apache to 2.4.52 or later.","what":"CVE-2021-44224 is a high-severity vulnerability in Apache Http Server, published on 20 Dec 2021."},"fix_prompt":"Check this codebase for CVE-2021-44224 and fix it if it is affected.\n\nWhat it is: CVE-2021-44224 is a high-severity vulnerability in Apache Http Server, published on 20 Dec 2021. \nExploitation: There is no known exploitation of CVE-2021-44224 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache (Bitnami): affected from 2.4.7; fixed in 2.4.52\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-44224/ (Markdown: https://insights.sbomify.com/CVE-2021-44224/index.md)","id":"CVE-2021-44224","markdown":"https://insights.sbomify.com/CVE-2021-44224/index.md","name":"CVE-2021-44224","record":{"aliases":["ALPINE-CVE-2021-44224","AZL-7043","BIT-apache-2021-44224","CLEANSTART-2026-GK10724","DEBIAN-CVE-2021-44224","GHSA-92ww-hwmg-qq7p","UBUNTU-CVE-2021-44224"],"analysis":null,"analysis_generated_by":null,"assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"},{"product":"mac_os_x","vendor":"apple"},{"product":"macos","vendor":"apple"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"},{"product":"communications_element_manager","vendor":"oracle"},{"product":"communications_operations_monitor","vendor":"oracle"},{"product":"communications_session_report_manager","vendor":"oracle"},{"product":"communications_session_route_manager","vendor":"oracle"},{"product":"http_server","vendor":"oracle"},{"product":"instantis_enterprisetrack","vendor":"oracle"},{"product":"tenable.sc","vendor":"tenable"}],"cvss":{"score":8.2,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-476","name":"NULL Pointer Dereference"}],"description":"A crafted URI sent to httpd configured as a forward proxy (ProxyRequests on) can cause a crash (NULL pointer dereference) or, for configurations mixing forward and reverse proxy declarations, can allow for requests to be directed to a declared Unix Domain Socket endpoint (Server Side Request Forgery). This issue affects Apache HTTP Server 2.4.7 up to 2.4.51 (included).","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Possible NULL dereference or SSRF in forward proxy configurations in Apache HTTP Server 2.4.51 and earlier","id":"CVE-2021-44224","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:http_server","products":["apache:http_server","apple:mac_os_x","apple:macos","debian:debian_linux","fedoraproject:fedora","oracle:communications_element_manager","oracle:communications_session_report_manager","oracle:communications_session_route_manager","oracle:http_server","oracle:instantis_enterprisetrack"],"type":null,"year":"2021"},"n_packages":1,"n_references":19,"next":{"headline":"Missing authorization in n/a","id":"CVE-2021-44225"},"packages":[{"ecosystem":"Bitnami","fixed":["2.4.52"],"introduced":["2.4.7"],"last_affected":[],"package":"apache","purl":"pkg:bitnami/apache","source":"BIT-apache-2021-44224"}],"prev":{"headline":"WordPress before 5.8 lacks support for the Update URI plugin header.","id":"CVE-2021-44223"},"products":["Apache HTTP Server"],"published":"2021-12-20","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Apache Software Foundation"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2021-44224/"}