{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2021-4428 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2021-4428 yet. Limit exposure of the affected software until one is available.","what":"CVE-2021-4428 is a low-severity vulnerability in what3words Autosuggest Plugin, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2021-4428 and fix it if it is affected.\n\nWhat it is: CVE-2021-4428 is a low-severity vulnerability in what3words Autosuggest Plugin, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2021-4428 in the wild and no public exploit code.\n\nAffected product: what3words Autosuggest Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2021-4428/ (Markdown: https://insights.sbomify.com/CVE-2021-4428/index.md)","id":"CVE-2021-4428","markdown":"https://insights.sbomify.com/CVE-2021-4428/index.md","name":"CVE-2021-4428","record":{"aliases":["GHSA-gf9p-c4mf-w382"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"high_privilege","summary":"Remote attackers can obtain sensitive information via the enqueue_scripts function in the what3words Autosuggest WordPress plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"autosuggest","vendor":"what3words"}],"cvss":{"score":2.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vulnerability is the function enqueue_scripts of the file w3w-autosuggest/public/class-w3w-autosuggest-public.php of the component Setting Handler. The manipulation leads to information disclosure. The attack can be launched remotely. Upgrading to version 4.0.1 is able to address this issue. The patch is named dd59cbac5f86057d6a73b87007c08b8bfa0c32ac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-234247.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":"2021-12-21","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2021-12-21T09:17:08Z","kind":"github_poc","ref":"https://github.com/CERT-hr/Log4Shell","stars":0,"title":"This repo contains IoCs which are associated with exploitation of CVE-2021-4428."}],"tier":"poc_unverified"},"has_fix":false,"headline":"what3words Autosuggest Plugin Setting class-w3w-autosuggest-public.php enqueue_scripts information disclosure","id":"CVE-2021-4428","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2021"},"n_packages":0,"n_references":5,"next":{"headline":"Ortus Solutions ColdBox Elixir ENV Variable defaultConfig.js information disclosure","id":"CVE-2021-4430"},"packages":[],"prev":{"headline":"Vuukle Comments, Reactions, Share Bar, Revenue \u003c= 3.4.31 - Cross-Site Request Forgery Bypass","id":"CVE-2021-4427"},"products":["Autosuggest Plugin"],"published":"2023-07-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["what3words"]},"summary":"Remote attackers can obtain sensitive information via the enqueue_scripts function in the what3words Autosuggest WordPress plugin.","url":"https://insights.sbomify.com/CVE-2021-4428/"}