# CVE-2021-4428: what3words Autosuggest Plugin Setting class-w3w-autosuggest-public.php enqueue_scripts information disclosure

> Remote attackers can obtain sensitive information via the enqueue_scripts function in the what3words Autosuggest WordPress plugin.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jul 2023
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-gf9p-c4mf-w382

## What is CVE-2021-4428?

CVE-2021-4428 is a low-severity vulnerability in what3words Autosuggest Plugin, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A vulnerability has been found in what3words Autosuggest Plugin up to 4.0.0 on WordPress and classified as problematic. Affected by this vulnerability is the function enqueue_scripts of the file w3w-autosuggest/public/class-w3w-autosuggest-public.php of the component Setting Handler. The manipulation leads to information disclosure. The attack can be launched remotely. Upgrading to version 4.0.1 is able to address this issue. The patch is named dd59cbac5f86057d6a73b87007c08b8bfa0c32ac. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-234247.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2021-4428?

It affects 1 product.


Products: What3words Autosuggest.

## How do I fix CVE-2021-4428?

No fix has been published for CVE-2021-4428 yet. Limit exposure of the affected software until one is available.

## Is CVE-2021-4428 being exploited?

There is no known exploitation of CVE-2021-4428 in the wild and no public exploit code.

Public exploit code:

- This repo contains IoCs which are associated with exploitation of CVE-2021-4428. (github_poc): https://github.com/CERT-hr/Log4Shell

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4428 and fix it if it is affected.

What it is: CVE-2021-4428 is a low-severity vulnerability in what3words Autosuggest Plugin, published on 18 Jul 2023. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2021-4428 in the wild and no public exploit code.

Affected product: what3words Autosuggest Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4428/ (Markdown: https://insights.sbomify.com/CVE-2021-4428/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4428
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4428
- OSV: https://osv.dev/vulnerability/CVE-2021-4428

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4428/
Summaries are generated and may contain mistakes; the official description above is the record.
