# CVE-2021-4435: Yarn: untrusted search path

> Attackers can execute malicious commands when victims run Yarn in directories with attacker-controlled content due to untrusted search paths.

- **Severity:** High 7.7 (`CVSS:3.1/AV:L/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2024
- **Updated:** 17 Jun 2025
- **Also known as:** CLSA-2026-1786471978, DEBIAN-CVE-2021-4435, GHSA-mpwj-fcr6-x34c, ROOT-APP-NPM-CVE-2021-4435, UBUNTU-CVE-2021-4435

## What is CVE-2021-4435?

CVE-2021-4435 is a high-severity path traversal vulnerability in Fedora Extra Packages for Enterprise Linux, published on 4 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

An untrusted search path vulnerability was found in Yarn. When a victim runs certain Yarn commands in a directory with attacker-controlled content, malicious commands could be executed in unexpected ways.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2021-4435?

2 open source packages ship an affected version, including yarn. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yarn` | npm | All versions | 1.22.13 |
| `yarn` | npm | All versions | 1.22.13 |

Products: Yarnpkg Yarn.

## How do I fix CVE-2021-4435?

Upgrade yarn to 1.22.13 or later.

## Is CVE-2021-4435 being exploited?

There is no known exploitation of CVE-2021-4435 in the wild and no public exploit code.

## Other vulnerabilities in Fedora Extra Packages for Enterprise Linux

- [CVE-2019-5448](https://insights.sbomify.com/CVE-2019-5448/): Missing Encryption of Sensitive Data in yarn (high 8.1)
- [CVE-2019-10773](https://insights.sbomify.com/CVE-2019-10773/): Yarn Improper link resolution before file access (Link Following) (high 7.8)
- [CVE-2020-8131](https://insights.sbomify.com/CVE-2020-8131/): Path Traversal in Yarn (high 7.5)
- [CVE-2019-15608](https://insights.sbomify.com/CVE-2019-15608/): TOCTOU Race Condition in Yarn (medium 5.9)
- [CVE-2025-8262](https://insights.sbomify.com/CVE-2025-8262/): yarnpkg Yarn hosted-git-resolver.js explodeHostedGitFragment redos (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2021-4435 and fix it if it is affected.

What it is: CVE-2021-4435 is a high-severity path traversal vulnerability in Fedora Extra Packages for Enterprise Linux, published on 4 Feb 2024. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2021-4435 in the wild and no public exploit code.

Affected packages and fixed versions:
- yarn (npm): affected all versions; fixed in 1.22.13
- yarn (npm): affected all versions; fixed in 1.22.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2021-4435/ (Markdown: https://insights.sbomify.com/CVE-2021-4435/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2021-4435
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2021-4435
- OSV: https://osv.dev/vulnerability/CVE-2021-4435

---
From sbomify Insights: https://insights.sbomify.com/CVE-2021-4435/
Summaries are generated and may contain mistakes; the official description above is the record.
