CVE-2021-4437 dbartholomae lambda-middleware frameguard JSON Mime-Type JsonDeserializer.ts redos

Low 3.5 Published Updated

An attacker can cause a denial of service via inefficient regular expression complexity in the JSON deserializer of the lambda-middleware frameguard library.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2021-4437?

CVE-2021-4437 is a low-severity denial of service vulnerability in dbartholomae lambda-middleware frameguard, published on 12 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A vulnerability, which was classified as problematic, has been found in dbartholomae lambda-middleware frameguard up to 1.0.4. Affected by this issue is some unknown functionality of the file packages/json-deserializer/src/JsonDeserializer.ts of the component JSON Mime-Type Handler. The manipulation leads to inefficient regular expression complexity. Upgrading to version 1.1.0 is able to address this issue. The patch is identified as f689404d830cbc1edd6a1018d3334ff5f44dc6a6. It is recommended to upgrade the affected component. VDB-253406 is the identifier assigned to this vulnerability.

Weakness: CWE-1333

Which versions are affected by CVE-2021-4437?

2 open source packages ship an affected version, including @lambda-middleware/json-deserializer. It affects 1 product.

PackageAffectedFixed in
@lambda-middleware/json-deserializer npmAll versions1.1.0
@lambda-middleware/json-deserializer npmAll versions1.1.0

Products include Dbartholomae Lambda-Middleware.

How do I fix CVE-2021-4437?

Upgrade @lambda-middleware/json-deserializer to 1.1.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2021-4437 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2021-4437 exists.

Sources

Also known as GHSA-m3f4-957x-m785.

Is CVE-2021-4437 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free